Topic: ioctl("TIOCMSET"): Broken pipe error raspberry pi 4 and seeeduino

i’m trying to upload a new program with a library called hx711.h and get the following error -

ioctl(“TIOCMSET”): Broken pipe

ioctl(“TIOCMSET”): Broken pipe

avrdude: stk500_recv(): programmer is not responding


a few exceptions that make it problematic -

  1. i’m using seeeduino lotus v1.1
  2. the seeeduino is communicating through serial with a raspberry pi 4 model B, also the arduino ide (adjusted for lotus) is controlled through the raspberry pi.

    order of events:

  • the seeeduino is working properly when i upload another program, let’s call it main.
  • then i dowloaded the hx711 library and uploaded an example program from the hx711 library.
  • received the error :" ioctl(“TIOCMSET”): Broken pipe"
  • tried to upload main program again, also got error:" ioctl(“TIOCMSET”): Broken pipe"
  • after a few reboots and ejecting the usb cable my main program is up and running again, but still have no clue how to activate the hx711 library and all that.

    my main suspicion is that i should’ve adjust the library to seeeduino somehow but i’m not sure how, and i’m not sure that is necessary. all i know is that when downloading the DHT22 library to seeeduino, i had to download a library specialized for seeeduino (which i didn’t find in the case of hx711).

    what do you think?

    awaiting your kind advice! :slight_smile:


Can you share the library link? I’ll try to check with my own.

thanks for the quick reply! (:

the library is called HX711 arduino library by bogdan necula,andreas motl

i searched for it in the library manager and dowloaded directly.

there are also other hx711 libraries that i wasn’t sure would work, i know the first one i mentioned worked just fine with the arduino mega i have.


I tried to replicate the issue by compiling the sketch for seeed lotus based on ATMega328, and I didn’t get any error.

can you try update to board definition and please let me know the output?