Timeout trying to flash A603 \ 4Gig Orin Nano

I’m trying to flash Jetpack 5.1.1 onto an A603\4 Gig Orin Nano. I’m following the wiki instructions to flash. Trying to flash to a USB thumbdrive.

I run the flashing command. It runs for awhile, gets to the flashing part and times out with “Waiting for target to boot up”. The device shows up in lsusb, and I remove the flash wire after that as stated in the instructions.

I found another post in this forum with a similar issue and they seemed to think the issue was with the storage device they were using. Is there any issues with flashing to a USB thumbdrive (gen 3.x)? I’ve tried putting the thumbdrive in both USB slots with the same failure.

Hi there,
How much ram is installed and what is the size of the Device. They need to be bigger than
others to do it with USB. Check the port is indeed in 3.0 USB, most have had better luck flashing the NVME directly.
HTH
GL :slight_smile: PJ

Are you sure you are in forced recovery mode?

Hi all,

I have exactly the same issue with an A603 board and an Orin Nano 4G module. When trying to flash an NVMe device it seems the device is not exposed to the PC for flashing. Curiously, if I connect an empty USB device to the A603 board the NVMe is correctly exposed and the flash process completes successfully. I have tried it many times with the same result: fail without USB, success with it. Please note the USB is not used at all, the device flashed is the NVMe.

I have the logs but I’m not able to upload files right now.

Hi! Any news on this? Flashing it’s a key point and if it does not work we should discard this board.

Attached I send the logs for the process when the USB device is connected (flash_ok.cap) and when it’s not and flash gets hung (flash_fail.cap)

flash_logs.zip (69,7 KB)