This board used to boot on ubuntu but does not with arch

Hi, I have a seeed odyssey j4105, without the eMMC and no win10 licence. I have used it well for 6 months as a desktop with ubuntu, on a 2280 ssd in the ssd slot, not the NVME slot.

Now trying to learn arch linux. I have followed the arch instructions perfectly with no errors as far as I can tell, but it boots to efi, listing partitions. it simply can’t see a bootable anything. In bios it can see usb drives but not ssd drives. I bought an NVME drive and tried that too, no better, still just goes to efi prompt. This clearly works as it did on ubuntu. It can ultimately see the partitions as it dumps to an efi console with yellow text on a black back ground, if you type ‘help’ it will list 60-100 commands. I can’t find a user guide for this.

Any ideas about where to look.

originally the ubuntu partition was on this:

I tried arch on it but no luck,
I got this:

but same problem.

The disk label on both was gpt, did it need to be mbr??

after using this super webpage:

I learnt to use efi commands to mount and read partitions. I found the EFI partition.

and learn that UEFI is weird for some manufacturer’s on the arch wiki:

I learnt that I needed to copy the grubx64.efi to the ‘fallback location’ using the efi commands, with the efi name.

please comment if you know a better way,

1 Like