Teething problems with Stalker

Hello Everyone,

I just got a stalker last week because I want to build a race timer for my running club. It looks like it’s just what I need but …

I cannot get the micro SD card to log data, using the code provided in the datasheet. It flashes the light in the setup routine when it makes the initial call to FileLoggger::append but never returns.

The card is a Lexar micro SD of 2GB capacity formated as FAT 16 with a file called data.log - this never gets any data stored in it.

I suspect that it is something to do with the card, but unless I can get another type of card to try I don’t think I will make progress now.

Is there a list of problem/good cards to use with the stalker?

Does anyone have any ideas about how to debug this, given the fact that the append call does not seem to return?

Many thanks for any help anyone can give me.


Hi Tony,

The stability of filelogger lib is not very well on stalker.
You may try the lib in the following link:



I’ll give it a go.

Some progress? Now at least I get error messages. When I run the fat16info sketch, I get the following:

FreeRam: 268

type any character to start
card.init failed
SD error
errorCode: 1
errorData: FF

I’ve tried other example sketches, but with no luck. When I tried the benchmark sketch I got apparently randomly different errors each time I ran it.

I will try to source another card, but this does seem to be much more difficult than I was expecting. As far as I am aware the card is OK, but if there are only a subset of cards that will work on this platform, then it would be nice to be given some ideas about which cards will work. After all it is a major feature of the Stalker.

Many thanks,


I just went out and bought another card - a Kingston 2G. It now runs the fat16info sketch - see below, but still having problems with the benchmark program. I’ll have a bit of a play with the other example programs now to try to get it going.

type any character to start

init time: 2

Manufacturer ID: 2
Product: SA02G
Version: 0.4
Serial number: 1493315740
Manufacturing date: 3/2010

Card Size(blocks): 3842048

Partition Table:

FAT Volume info for partition: 1
Volume is FAT16
clusterSize: 64
clusterCount: 60022
fatCount: 2
fatSize: 235
totalBlocks: 3841911

Root Directory:
name ext att size


pe any character to start Free RAM: -112 error: Fat16::init failed! SD error: 3

Just tried the fat16AnalogLogger sketch using a potentiometer to generate ‘interesting’ input’.

IT WORKS! No idea about the benchmark - it might be running out of memory?

Now the question remains, was the Lexar card unsuitable, or what?

millis,sens0,sens1,sens2 8000,420,406,437 9000,419,399,361 10000,424,429,334 11000,424,439,381 12000,418,440,437 13000,417,395,402 14000,419,391,366 15000,422,387,330 16000,421,426,318 17000,424,440,418