(TECH) Touchscreen lost calibration

I successfully got my RePhone working yesterday and set up the address books, added ring tones etc. Later in the day I tried to use it, and found that the screen did not respond correctly to touches and the phone seemed to hang once I had pressed the screen a few times. Also, the main button will not turn the phone off, I have to unplug the battery. I have tried the following:
Reseat the 35 pin cables to the GSM and audio modules
Replace the 35 pin cable to the GSM module
Re-flash the phone to the latest version (v6_4)
Remove the audio module
Edit: The main button powers the unit on and off with the screen detached from the GSM module

So far nothing has improved the situation. The screen does respond to finger presses, but almost backwards. Pressing the lower right corner results in a selection of the lower left corner. Sometimes the center of the screen responds correctly, but other times it doesn’t respond or responds backwards.

What should I try next to identify the problem please?

Thank you,

Jon (like Charlie, in Houston)

Maybe something wrong with the hardware of touchscreen. I think in this situation, maybe you can contact their customer service for help.

I have mailed techsupport but with no reply.