(TECH) Couldn't install Xadow Duino Driver

Hello everyone, I am having a very basic issue here with my xadow duino.

I powered up my xadow duino and plugged it into my win7 laptop. The device manager showing other devices: “Seeeduino Xadow”

So I continued with installing the driver by selecting the folder downloaded from https://github.com/Seeed-Studio/Signed_USB_Serial_Driver

Guess what?

Is there anyone having the similar issue?

I have tested on another computer but still no luck. The driver name seems like doesn’t match the device name.

Computer detected Seeeduino Xadow, however the driver provided contained
Seeeduino V4
Xadow Clio
Seeeduino Cloud
Seeeduino Lite…and etc

Still struggling to get the driver installed. :neutral_face:

I found Github about Xadow Duino driver, maybe you can try it again.

Hi jinyuan.weng,

Thanks for informing.

Seems like Seeed studio is working on the issue. Will surely try it out once I get home and update the result.

I got a Bluescreen while installing new driver from https://github.com/WayenWeng/Xadow_Duino_Driver/ with the Xadow duino plugged in.


If I use update driver option and choose the file location that contained the inf driver I just downloaded, I got back the same message from win7

Still couldn’t get it solved. :cry:

Have ordered another piece of Xadow Duino. Wondering if i have received a faulty one which causes this weird driver issue. Hmmm…

Hope it is a hardware issue. Have tried on few different computers and the results are the same. Will update again once the new board arrives.