(TECH) can't get CreateKit working with any non-default vxps

Hi there!
I’m not sure if my problem is related to this thread, but I’ve following situation:
I’ve unpacked CreateKit, connected particles each to other (LCD-GSM-antenna-battery-audio) and tested it a bit on the default stock firmware which it has when I unpacked it.

Then I tried to download new version (github:WayenWeng/RePhone_Create_Kit_VXP, sorry, forum said my message is to spamy due to this link) of the firmware (or how should we call vxps? applications?).

But all that I see when power device on after flashing (copying MRE/*vxp and autostart.txt) — LED on GSM module is lighting green (not even blinking like on “default” 6.2). And that’s all. Nothing on the LCD, even no debug ports (if connected via USB while powering on). AFAIRC, only gsm-modem port (/dev/ttyUSB0).
Although, after powering it off and mounting as flash disk, system log shows successful start :-/

Then, when I tried to install Lua-for-RePhone, using this instructions (downloading release zipball from github, unpacking it, copying it content to the 5MB flash disk), and tried to boot in into that firmware — I having nothing on LCD too (although, I assumed that), but I also have nothing in debug port (/dev/ttyACM0, which meant to be COM4 in Windows example on wiki), when connecting to it with either putty, minicom, or whatever. And tons of binary data, when connecting to ttyACM1 (which, probably, assumed to be “Modem port” aka “COM5” on that windows screenshot on the wiki).
So, neither of that ports provided Lua console in PuTTY, while wiki suggests opposite.

So, I’m now in kinda frustration: am I doing somwthing wrong, or my kit is broken?

anyone? :frowning:

Have you renamed the autostart.txt according to the new vxp file? :slight_smile:

@dbelam Do you mind elaborating on that a bit? I’m having the same problem as the OP.

With my Rephone freshly reflashed. Plugged in to USB. In Mass storage mode. With the device storage open “Removable Disk (J:)” in my case. The folder is empty. That’s correct I think.

Now I copy and paste the unzipped contents of the Create Kit VXP folder into the mass storage of the phone. Right?
Now I have two items there. An MRE folder and an autostart.txt file. However when I restart the phone it only has a backlit screen and the LED is purple.

What would I rename? The autostart.txt file to RePhone_Create_Kit_v6_4.txt? I tried that and it didn’t work.

Any help would be great. Thank you

Also, I have tested my SIM with this device and it works for sure…

@bconstructive, I think, @dbelam meant editing, but not renaming. And, yes, I do have tried to edit it (initially) and write proper path to vxp-file, and when there was no effect - I just copied it from the github repo.

Anyway, it seems, that (at least, lua.vxp partially working: it DO add two ACM ports in the system. But there is just no lua comand prompt in any of them.

And, RePhoneKit6.4, according to log-file, working too. Just do not show anything on the screen (although, it is only constant green light for me, and no purple, like it was in “default” 6.2.

Well I first reflashed my rephone and copied the initial structure, since then when I copy any new VXP next to the other and edit the autostart to start the new VXP, it works :confused:

@seeed86 Total goofball move on my part, but my speaker/mic module was connected to the screen backwards. When the speaker mod is connected to the LCD with the mic closest to the LCD the screen works fine. In that, it displays the factory VXP screen with call, text, lightbulb, etc. buttons as it should. When the speaker mod is connected other way around(mic farthest away from LCD) all I get is a backlit LCD.

Might not have anything to do with your situation. Perhaps if someone is having a similar problem they should try switching the orientation of that hardware piece.

UPD: It seems, somehow I started rephone’s 6.4 vxp (while I still on old “firmware” (bootloader and so. I.e. I didn’t “flashed” anything, only playing with mass storage mode, since I can’t see a way for firmware upgrading on non-windows hosts)), and it creates ttyACM{0,1} files too (as lua), when started.

And… there are all the same in ACM-ports: nothing in ACM0 (looks like it is modem port, while it answers on AT-commands, so I was mistaken in OP) and tons of binary crap in ACM1 (which should be debug port then, I assume).

So, I mostly discouraged with the fact that PuTTY on the RePhone’s wiki shows lua command prompt with only single setting changed (assuming CR on LF), while I see tons of crap there in both PuTTY an minicom (maybe there is some another recommended software for unixlike hosts?).