'TCA9548A' is not a template problem

I’m trying to connect several sensors to wio terminal.
I tried to use 8 channel I2C multichannel hub but it’s not working so now I’m trying to check the 8 channel I2C multichannel hub.
I connect one senor (BME680) which is connected to the 8channel hub and connect 8channel hub to wio terminal.
( Wio terminal - 8channel i2c hub - BME680 (i2c0) )
I added the library and run the example, but there’s an error as below.

  • ‘TCA9548A’ is not a template.

Please share you advices.
Thanks a lot in advance!

Hi, seungeunlee
Now it’s hard to judge the cause of the problem. I hope you can provide the program code. We’ll find the relevant hardware and test it before we reply to you.
Look forward to your reply.

Hello, I’m new here, so I can’t upload the code right now… It is not uploaded…
But I just used the example code for this 8 channel i2c multiplexer in the link below.

Well, this problem is a bit strange. I found the hardware you mentioned and tested it with the same program, and it worked fine. Below is a screenshot of the hardware connection diagram and the serial monitor.

Can you take a picture and let’s see how your hardware is connected.

The connection is the same…
The error popped up when I verify the code (not upload), so it doesn’t look like a problem of the hardware…
I don’t know why it doesn’t work…
Do you have some any other idea that you can suggest for me?..

Our programmer noticed that the version of the Arduino IDE you are using is 1.8.12, and he recommends that you upgrade to the latest version and try again.
Hope this suggestion is useful to you.