(SW/HW)Serial communication impossible Yun <-> GPRS Shield

Hi all,

we have an Arduino Yun laying here, with which it is impossible to get communication between it and a seeedstudio GPRS shield. We’ve tried both via software serial as well as hardware serial. In the latter case, we are aware that it might interfere with the bridge between the 2 processors on the Yun.

The sketch we’re using can be found at the following wiki link from the seeedstudio’s website under step 1:

seeedstudio.com/wiki/GPRS_Sh … T_Commands

Because the Yun shares similarities with the Arduino Leonardo, we understand that pins 8 through 16 can only be used.

So, the pin configuration is now as follows:
10 + 11 on Yun go to 0 (rx) and 1 (tx) on the GPRS Shield.

When we configure the shield to use hardware serial communication, and check Serial.available(), we only get ‘63’ as response, which might have something to do with the 64byte limit of the Yun’s memory, correct?
When we configure the shield to use software serial communication, and check Serial.available(), the only thing that gets returned is “0”.

We’ve already tried the altSerial library (which uses pins 5 and 13 on the Arduino for communication), but unfortunately without any luck.

What could be the problem? What else can we try to make the shield work properly with the Yun?

I’m bumping this topic because I have had similar problems.

Your setup looks good, however when using software serial you should:

  1. Set the jumper to software serial
  2. use port 7 + 8, which are the sofware TX and RX

In case of the Yun you should only use port 8 or higher for this purpose, 9 can be used for software startup of the shield, so connecting it to 10 & 11 is perfect. Give it a try, works for me.

What I noticed though, is that the Arduino does not supply the Shield (also v2) with enough power. I tried to power the shield with a 5v and 2.5amps powersupply. However this seems to disrupt communication, making it impossible to send AT commands.

Does anyone have an idea to fix this issue?