Stuck on firmware update screen

Hi Everyone,

After attempting to flash BenF firmware to a number of DSO nano’s, they now just power on to the DFU screen, even without pressing the down key which is normally required to launch the updater. I have tried to go back to the ‘Official version’ and that too fails. It appears that the DFU is doing everything as expected i.e “.RDY” files, but on a power cycle the device goes back to the DFU.

DFU Version: 3.45D
H/W Version: 3.02

I’m having this same issue, did you ever figure it out?

No, I still have the issue. I have not had much help from the customer support teams either.

I’m also stuck on this firmare screen, no matter what i try.
Any idea how to fix it?

Device firmware Upgrade: v3.45D


I managed to recover my device using a TTL-UART interface.
I did try this in the past but never managed to get a connection to the device.
The problem was that I was routing the cables like so

By chance, in I found a manual which explained how to flash the bootloader and i noticed that they mentioned to connect like so:

And that was it!

After successfully connected to the DSO Nano v3, I used Flash Loader Demo to perform the following steps in order:

  • downgraded the bootloader to v3.29D
  • Added my Licence number back (don’t forget to write it down before flashing the bootloader) using DS201.Unlock.V1.00.hex
  • and then proceed with flashing (16.7 KB) (14.8 KB) (53.5 KB)

1 Like

I tried this process, although the process works I am still an stuck in a loop with the DSO just booting to the DFU every time.
What version of hardware do you have?

I have the latest one, the one that came with bootloader v3.45D

Are you sure you downgraded the bootloader to v3.29D

What do you see in the DFU screen?

I also tried this, was able to successfully downgrade to 3.29D, but now I can’t get the virtual DFU drive to work correctly in Windows or MacOS. Any ideas? Do you think the firmware could be flashed via UART?

Did you try reflashing the bootloader again?
Did you add your license number?

I haven’t used this device in a very long time but i remember that once i did those 2 steps, i could easily proceed with the firmware upgrade.

What do you see in your device?

yeah, i repeated the process a couple of times (flash bootloader, flash unlock, enter license key) to no avail. when booted into dfu mode, it says ‘device firmware ver 3.29’ along with the serial and license, as well as a message to copy a hex file to the dfu drive.

isn’t that the last step that you need to do?

  • proceed with flashing

Download the Zip file, uncompress it and you’ll have there the 2 .hex files that you need to use to flash the device