Strange problem with charging DSO nano, benF 3.64

Hi there,

I’ve recently (just now!) had an issue with the device and it’s failure to charge.

I was using the device last night testing out an H bridge driver for a cutting machine when the battery got quite low so I gave in, turned it off and put it on charge (plugged into computers USB port all night) like I usually do at night.

Turned it on this morning and the battery is still dead, hasn’t charged at all and when it is turned on and I plug the USB lead in, the screen goes blank!

This is an absolute nightmare cause I’m currently in the middle of something and need this little device to work!

Any ideas?!

Just an update, I’ve just opened the DSO nano. Turns out is a DSO201V2.5 it says on the mainboard.

I’ve also noticed some slight charring around L3 and that L3 has completely blown out of the side!!!

I was only measuring a 30V signal last night and then plugged into my USB to charge for the night, so, what’s happened?!

Has anyone got a schematic that I could browse through to find out what L3 is?


Just found a 2.3 schematic, can’t imagine is being to dissimilar to the 2.5?
Eitherway, the L3 is a ferrite bead.


Seems Like I’ve fixed it! I know it’s a bit of a bodge as I don’t have any 0805 ferrite beads to hand, but I’ve fixed it using a 1515 sized SMD inductor, 22uH. Obviously not idea, but it is only on the return side from the charging circuit.

I wonder if the USB cable ground detached during the night leaving the 5V floating with no ground reference, could have caused something to pop perhaps?

Just had the same problem just now but with factory shipped firmware. (The USB symbol was also permanently stuck on.)

Unplugging the battery and then back in seemed to have resolved it.

If you left the probe connected to the circuit under scrutiny it could well be some nasty ground difference loop when you plugged the USB in the (laptop and ungrounded?) PC or so…