Stalker v3.1 with Maxbotix Sonar - Strange behavior

Hi all,

I’m creating this post because I’ve got some weird issues with this setup and I can’t understand why. So here’s the story :

I plugged the MB7363 Sonar sensor from Maxbotix to the Seeeduino Stalker v3.1 . I used the analog pin of the sonar (pin 3) and I connected it to the analog A1 input of the Seeeduino Stalker, Vpin to the 3,3v and GndPin to the GND pin, as you can see in the following picture :

I also added a 4LED display to show the value of the sonar from the analog input, again, as shown on the picture (maximum value is 1001).

Everything work fine this way, but when I want to remove the LED display, the value of the analog input coming from the sonar drops to 0. If I reconnect the LED display, correct value from the sonar start being read again. Thing is that I use the LED display as debug and I need to remove it at the end to put this setting (Seeeduino Stalker connected to a battery) in a closed box. Leaving the LED display will use too much power.
So, is there anyone here that have any idea about what is going on here and how can I make it work without the LED display ?

Here’s the code I used :

// include 4LED library /////////////
#include <TM1637Display.h>

// Variables 4LED //////////////////////////////////////////////
const int CLK = 3; //Set the CLK pin connection to the display
const int DIO = 9; //Set the DIO pin connection to the display

TM1637Display display(CLK, DIO); //set up the 4-Digit Display.

//Set the Maxbotix pin to receive the signal.
const int anPin = 1;

long pulse;

void setup()
/// 4LED Setup //////////////////////////////////////////////////////
display.setBrightness(0x0a); //set the diplay to maximum brightness

//Open up a serial connection

//Main loop where the action takes place
void loop()
pulse = analogRead(anPin);

Serial.print("The value is: ");


I did some others tests, and this became much weirder. So, I removed all the code about the LED display, and still not working (value stay on 0). So I tried connecting the LED display to see how it react, despite the fact there was no code about it. When I plugged the power and ground wire on their respective pin on the Stalker, and one of the two (CLK or DIO, doesn’t matter which) on DIGITAL PIN 9, sonar reads corrects values again… The 4LED does not show any value (of course, no code was written about, and wires are not all connected), but the sonar works…

So I tried something else. I removed the 4LED module, and wired the 5vcc Stalker pin directly to the DIGITALPIN 9. Sonar works and read correct value. Thing is, I don’t know why it works that way. I tried on other digital pins, and it doesn’t work. It’s only on digital pin 9. Is it possible that some trash code is left somewhere on the Stalker and it somehow wait to get signal on DPin 9, or do I have a Stalker that is messed up ?

Does anybody understand this?Can you help him?