[Solved] SD Shield problem - Help please!

Hi there!

I’ve just bought a Seeedstudio SD Shield [0] and I’m getting stuck since the beginning so, as you can figure I’m pretty new with Arduino and I hope you could help to troubleshoot this issue.

Next are the components I’m using:

  • Arduino UNO R3,
  • Seedstudio SD Shield v4.0b,
  • microSDHC to SD adapter (the one provided by seedstudio),
  • Sandisk microSDHC card 4Gb

So now:

  • SD Card shield pins are not soldered, just mounted as it is provided.
  • microSDHC card was formatted under linux using the next commands:
  • fdisk /dev/sdb
    ** (deleting any existing partition and creating a new one, everything by default)
  • mkdosfs -F 32 /dev/sdb1
  • mounted the new partition and checked that the partition exists and everything works there.

Once I mounted the sd shield on the Arduino UNO, then inserted the sdcard into de adapter and the into the sd shield. Then plugged it to the pc and uploaded the code from the Seeedstudio wiki [0], last section, the code for big partitions. Then uploaded it and got this error:

Initializing SD card…initialization failed. Things to check:

  • is a card is inserted?
  • Is your wiring correct?
  • did you change the chipSelect pin to match your shield or module?

Now, it seems to not been reaching the sd card in anyway. Not to be related to the filesystem.

  • Is a card inserted? YES
  • is your wiring correct? don’t know…
  • did you change the chipSelect pin to match your shield or module? for Arduino UNO it seems to be CS = 4. So the code that is in the wiki would be correct. Right?

What am I doing wrong? Could you please help me to troubleshoot this?

[0] seeedstudio.com/wiki/SD_Card_shield_V4.0

Thanks a lot in advance,

Solved once I soldered the pins :smiley:

See you!