SOLVED! Problems with SHT35 grove sensor and seeeduino


when trying the new grove sensor SHT35 with my new seeduino (v. 4.2), I can’t compile the example sketch, although downloaded from github as indicated there.

First there was an error I found out: During compiling there was called “arduino.h” instead of “Arduino.h” - I fixed it and got a new error message I can not find out what it is:

</s>/home/markus/sketchbook/libraries/Seeed_SHT35/Seeed_SHT35.cpp: In member function ‘err_t SHT_IIC_OPRTS::read_bytes(u8*, u32, clk_skch_t)’: /home/markus/sketchbook/libraries/Seeed_SHT35/Seeed_SHT35.cpp:265:44: error: ‘yield’ was not declared in this scope while (0 == digitalRead(SCK_PIN)) {yield();}<e>

Can anybody help me with some hints what to do?

Thank you very much!

Cu Markus


to be more exact: When using the original sketch “basic_demo” from the github package of the SHT35 sensor, then I get the following error message:

</s>In file included from basic_demo.ino:32:0: /home/markus/sketchbook/libraries/Seeed_SHT35/Seeed_SHT35.h:36:18: fatal error: Wire.h: File or Folder not found #include "Wire.h"<e>

So I first included the Wire.h-library in this “basic_demo” and then got the message I posted before (about a wrong “yield”).

Of course, I have installed the wire-library beside the sht35-library, so I have no idea why it is still missing - and why I get the “yield”-error when including it expressis verbis in the sketch.

May be this can help somebody to figure out what I should do…

Thank you for your attention!

Cu Markus

I found the solution by myself:

The arduino-version I installed by “apt-get install arduino” was deprecated - after downloading and installing the actual arduino package from the arduino homepage, I just had to adopt de screen baud rate to see the result: the example sketch worked out of the box.

I apologize for my beginners mistake - I hope at least that other beginners with similar or same problem can learn from it :wink:

Thank you for your attention!

cu Markus