[SOLVED] Gabonator + Pawn + Original App same time?


I’m trying to install Gabonator as app #2, Pawn as app #4 and still have access to original app (#1, primary).
The problem that i’ve encountered is that one of the apps is always just beeps (in case with original app - beeps after scroll press/move) and hangs.

Did someone try to do it? Am I doing somehing wrong or there’s some kind of black magic that should be applied?

P.S. HW: 2.72, APP: 1.10

UPD: After reading Gabonator issue list I’ve found that there’s such bug already (at GitHub #23, can’t insert link, sorry :frowning:) - installed Gabonator as App #3 and everything worked out just fine.

That’s not actually a bug. Several of the main Oscilloscope Apps including the stock one, Community and Wildcat take up 2 slots normally. So if you load them into slot 1 then they actually occupy slot1 and slot2 and if you load another app like Gabonator into slot 2 then you overwrite half of the main app.

Gabonator only occupies 1 slot because it is uses extra memory which was discovered to exist on the processor but not part of the original specification.

The Fourpack thread actually does this for some of the main apps so they only occupy one slot but that is currently only for the older 2MB devices not for 2.72h/w

I see, didn’t know that, thanks for info. I’m ok with it installed in slot #3, but after you’ve mentioned “Fourpack” thing I’ve tool a look at it and it looks very interesting, but as you’ve said it doesn’t support 8MB :frowning: I’ve asked author about what needs to be done to make it work and if he’ll answer I’ll try that.