SOLVED: Can't get the seeed studio BT to connect

Hi everyone! I am new to the this BT communication :confused: Ok, my end goal is to connect my android phone via the Arduino Commander app to my arduino board that is controlling different motors. I have purchased the seeedstudio BT Shield, gone to their website for instructions, read through the Wiki (and did everything it says to do), searched online for videos or simple instruction guides (no luck) and can’t get it to connect through the SSCOM3.2 app provided on the Wiki(which worries me because I am not even going to be connecting through that software, I will be connecting through my phone). I changed the code (see Wiki seeedstudio.com/wiki/index.p … oth_Shield) as instructed for the latest version of Arduino and the sketch uploads to the board. After that, the SSCOM3.2 should let me know that the BT sheild is inquireable (I am trying to set as slave) but it does nothing. (One thing to note, on the wiki, the ComNum on the middle right side of SSCOM3.2 is COM156… mine is empty, I don’t think I set up something correctly but can’t find instrcution on the Wiki)

I am looking for instructions, or a starting point to read up more on connecting via BT. It would be great to talk to someone who has used the seeedstudio BT shield and had it work correclty. Any help is better than I have now :confused: Thanks.

[code]/*
BluetoothShield Demo Code Slave.pde. This sketch could be used with
Master.pde to establish connection between two Arduino. It can also
be used for one slave bluetooth connected by the device(PC/Smart Phone)
with bluetooth function.
2011 Copyright © Seeed Technology Inc. All right reserved.

Author: Steve Chang

This demo code is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

For more details about the product please check http://www.seeedstudio.com/depot/

*/

/* Upload this sketch into Seeeduino and press reset*/

// old line: #include <NewSoftSerial.h> //Software Serial Port
#include <SoftwareSerial.h> //new line
#define RxD 6
#define TxD 7

#define DEBUG_ENABLED 1

// old line: NewSoftSerial blueToothSerial(RxD,TxD);
SoftwareSerial blueToothSerial(RxD,TxD); //new line

void setup()
{
Serial.begin(9600);
pinMode(RxD, INPUT);
pinMode(TxD, OUTPUT);
setupBlueToothConnection();

}

void loop()
{
char recvChar;
while(1){
if(blueToothSerial.available()){//check if there’s any data sent from the remote bluetooth shield
recvChar = blueToothSerial.read();
Serial.print(recvChar);
}
if(Serial.available()){//check if there’s any data sent from the local serial terminal, you can add the other applications here
recvChar = Serial.read();
blueToothSerial.print(recvChar);
}
}
}

void setupBlueToothConnection()
{
blueToothSerial.begin(38400); //Set BluetoothBee BaudRate to default baud rate 38400
blueToothSerial.print("\r\n+STWMOD=0\r\n"); //set the bluetooth work in slave mode
blueToothSerial.print("\r\n+STNA=SeeedBTSlave\r\n"); //set the bluetooth name as “SeeedBTSlave”
blueToothSerial.print("\r\n+STOAUT=1\r\n"); // Permit Paired device to connect me
blueToothSerial.print("\r\n+STAUTO=0\r\n"); // Auto-connection should be forbidden here
delay(2000); // This delay is required.
blueToothSerial.print("\r\n+INQ=1\r\n"); //make the slave bluetooth inquirable
Serial.println(“The slave bluetooth is inquirable!”);
delay(2000); // This delay is required.
blueToothSerial.flush();
}

[/code]

Ok, my issue was the COM1 port. The Arduino board in the device manager was COM3 and the Arduino 1.0.1 program was also COM3 (obviously) but the SCOM program is looking for COM1. I just noticed that it was COM1 because of everyone’s pictures of the program saying “Device is Inquireable!”. Anyway, I changed everything to COM1 and now my “Device is Inquireable!”.

Two issues happen now, my phone - Dell Streak Android 2.3 - doesn’t find the BT Shield. I used the standard BT discovery on the phone, Bluetooth Class Zero, and Arduino Commander and none found the device :/… please help haha

The second issue is that COM1 is used now and my serial monitor won’t work because apparently it runs off COM1? When I try to open the Serial Monitor on Arduino 1.0.1, on the bottom the main message is “Serial port ‘COM1’ already in use. Try quiting any programs that may be using it.” I guess that is what SSCOM3.2 does is monitor the Serial Communication.

The BT board is blinking and I did get the SCOM app to say:

WORK:MASTER

+BTSTATE:0

+BTSTATE:1

Tried today with my Dad’s Epic 4G and still no luck :confused:

Hi ,
Ignore the SSCOM3.2 app . Firstly , you need to check the jump cap is right that same as the picture of wiki page. And then , upload the demo code that you showed . After upload the code ,open the monitor of arduino IDE. blue and red LED of BT shiled should be blink in turn later. Then you can pair it by you phone .

Deray

Ok, I uploaded the code but only a green light is blinking on the BT shield. The jumpers are in the correct location but my board looks slightly different than the wiki one. I think there have been slight modifications on it. Regardless, I know that part of the code is working because it has said the shield is inquireable, but leaving that alone, I will re-run the code without SSCOM at lunch and see if it works. I don’t know what else could be wrong :confused:

I GOT IT!!! I’m surprised no one noticed by the State:1 State:0 code, but I didn’t either so hey… The bt shield was not seated completlely on the arduino… onced I pressed it down firmly, the board now blinks red and green and I am able to connect to my phone!

Thank you every1 for your help!