SIM card registration fails **EdgeBox-RPi-200*

We have used EdgeBox-RPi-200 and have not had issues with SIM registration before.

We are now having issues with this recent batch we have purchased from Seeed.

Has anyone had this issue?

Please help!

I think the hardware must be checked. Hope seeedstudio will contact you and take this initiative soon.

What is the SIM registration problem you are referring to? Perhaps you could describe it in detail

We have the SIM inserted correctly into this unit and the SIM we are using has been tested in a known working RPI-200 unit. so SIM confirmed working. We have purchase a number of these units and are quite familiar with them.

Using Mincom I send at+cip? and we get Error 10. Is it possible hardware issue?

exact error:

Hi there, have you tried the full output?
SIM status and presence:

First enable the extended error codes to get a verbose format,


Now get the status of SIM presense,

+CME ERROR: SIM not inserted

Above AT command response indicates that SIM card is not present. Verify that SIM is inserted properly and check again,


When the SIM card is ready, above AT response will be received from the module.

GL :slight_smile: PJ

It sounds frustrating! It could be a firmware or batch issue. i faced same issue and i contacted Seeed for support, and tested the SIMs in a different device to rule out hardware issues. one of my friend had the same issue regarding sim Registration of TM but his issue was solved from here :