Setting a Static IP Address

Has anyone been able to successfully set a static IP on wlan0 interface using the 20180801-lxqt-sd image? I’ve tried a number of different ways that work on a normal Debian-based distro and none of them work on this image. I can get a DHCP-assigned address on my wlan interface, but that’s it – and even THAT ignores the fixed-address that’s configured as a reservation for the RSv2’s MAC address on my DHCP server.

What I’ve tried:


  • [*] Setting a static address in /etc/network/interfaces
  • [*] Directly editing /etc/NetworkManager/system-connections/
  • [*] Using nmtui to edit the connection file
  • [*] Placing a reservation for the wlan0 interface's MAC address in my DHCP server's dhcpd.conf file.
  • [/list]

    #1 appears to assign the desired static IP, but the RSv2 can’t reach any other hosts on my network

    #2 and #3 result in no IP address assignment to the wlan0 interface at all

    #4 is ignored. The interface gets an address from my DHCP server, but not the assigned fixed-address in my configuration file.


    Disregard. Although I’d love to know what the issue was, I restarted with a clean installation of the image. After setting a static with the nmtui-edit tool I got the desired IP assigned.