Set up Respeaker mic array v2


I am trying to get started with my new Respeaker mic array v2.

When I connect it to win7 or win10 / Notebook. it´s an unknown device.

On win10 I recieve the message “unknown usb device (device descriptor request failed)”

Is this common, did somebody tried the board with windows? Or just Linux and MAC?

Is there any driver package for the V2 version?

I found only drivers for the V1,but this is a different chip.

I tried different cables, different usb ports, and notebooks?

thank you.


Hi there, it works with mac,linux and windows as well. it is usb1.0 protocol. please try to install dfu and led control firmware and see if it solves the issue. thanks.

<LINK_TEXT text=“ … rol-driver”></LINK_TEXT>


I am having a similar problem. The device works great on mac and linux but will not work on several Windows 10 laptops. I’ve tried several different options including the use of the drivers for the DFU and LED control firmware and it still does not work.

In some cases it shows up as a “composite device”.

It does not show as a recording device currently, although did before we restored our test laptop. Even then the audio did not make it through stably to the code running in a Chrome browser. (This works successfully on the chromebook, mac OS, and linux devices)

We want to use this extensively and order a few hundred units but our users predominantly use Windows laptops so we can’t continue with this hardware unless we can find a robust solution to the windows issue.