Serial RF Pro [SerialRFPro] not working properly


I tried asking for help via Technical Support form more than a week ago, but so far, no answer.

I’ve ordered in the last few months 4 units of the Serial RF Pro, two of them came as version 1.0 and the other as version 1.1. The 1.0s are working fine! But the 1.1s are working erratically. I left both of them in different computers running the demo code to see the serial monitor output. What happens:

  1. Most of time one (or another) does the TX (red light) all the time, but only RX for a short time (5 to ten loops) or even minutes, but ALWAYS stop RX. It only return RX after reseting;

  2. Sometimes they stuck with the red light on after booting or after few minutes working as it should;

  3. Everytime the serial monitor gets something, it’s like this (no matters if it was TX from a 1.0 or 1.1):



    Instead of the persistent answer that occurs between both of the 1.0s:

It always skips one signal.

Did you change anything more than the config jumper place from ver 1.0 to 1.1? Or maybe I got a bad batch? Do I need to configure them properly? I’m running with the exact demo sketch on the wiki, with the antennaes attached to the correct pin hole and I tried this with all seeeduinos, Arduino Leonardo and Mega 2560 that I have. Always with the same errors.

I need something that I can rely on, because this project will be inside a enclosure and I need to be sure that I will not have to reset every few minutes. It would be a ponitless application. :neutral_face:

Besides that the modules are pretty expensive to “only work sometimes”.

Please help me!

Thank you,