Serial not working

Hey guys,

I was trying to run the Wifi example provided in secton 5.3 of the official Developer’s Guide.

However, I can see nothing from the Serial Monitor in the Arduino application, nor any errors show up.

The Arduino version I use is 1.5.8, I tried this on a 64-bit Windows 7 as well as a 32-bit Windows XP, both resulted in the same behaviour. So my question is: is there any particular setup I need to make serial working here?

Thanks a lot!

look into the forum

under can`t run wifi and gprs

add 2 lines into the sketch and you see your serial

Thanks for the reply!

Unfortunately, this doesn’t seem to work for me. Any idea what else might cause the problem?

For the record, I can’t even make the following code print anything:

void setup() {

void loop() {

So, I really don’t think the problem is that Serial works too fast. Is it possible that my board is just broken?

Hi, does the LinkIt ONE works fine ever?
And about the usb port, do you choose the modem port?

Aha! You solved my problem: turns out that I didn’t use the modem port when launching Serial Monitor.

Thank you so much!

To program the LinkIt ONE you need to use the Debug port.
But to see the Serial output you need to use the USB Modem port

On my PC Debug port is COM18 and USB Modem is COM19 (check the Device Manager to see which are which on your PC)

So I set Arduino IDE to use COM18 and then I open TeraTerm terminal and connect to COM19 to monitor the Serial output

I have the Linkit USB ports appearing correctly when Linkit one plugged in to my PC viewed by Device Manager.
Can upload programs but it locks the Linkit and ports disappear on end of upload reset?
Reset at any time also generates a port loss and locks linkit.
Linkit can be recovered by resetting on battery or plugging into my laptops USB.
Uploaded program then functions.
reconnection back to PC USB, ports appear OK.

In Summary ‘Reset’ of LINKIT one connected to PC USB loses ports and locks Linkit?