Sensecap T1000 GPS Tracker failed firmware upgrade - Now stuck with blinking LED

Hi there,
I tried to apply the firmware update from version 1.4 (I think) to 2.2 (I think) today. The process started by erasing the existing firmware. After that, it started flashing the new firmware. However, the flashing failed at around 21%.
Now the tracker seems to be broken. The LED blinks constantly every 2 seconds (1 second on, 1 second off). The device is visible as a Bluetooth device named “SENSECAP_GR_DFU_801975”. I tried several button press durations and combinations, but this behavior can’t be changed. Not even exited, i.e., I can’t turn off the sensor.

The app is able to connect to this device for another firmware upgrade. However, I am faced with only one option, namely “upload Firmware File”, where it wants me to select a local file to upload. I don’t have any such files, and I can’t find a place to download it online.

Can the support team please provide a firmware file?

Got my T1000-A today and first thing in the “sensecap mate app” was a hint of firmware upgrade (1.4 to 2.5). Started the upgrade, flashing after erasing finished 100%. After that a “failed” appeared.

Since then the same status as @TomStein. How to resolve this?

What a pity to hear that @thessy. I haven’t touched the tracker again and still have the problem. I am waiting for a response from seeedstudio.

Edit: maybe the battery is empty by now and I can reboot the device by powering it up externally. I will check this next week.

Hi there,
So I asked the Great “G” ----> sensecap version 1.4 download
It replied with 2 links , The first is a source for the files to download…
the Second was Your link here asking the Q. LOL
Idunno if it helps but here is what I found.

https://install.appcenter.ms/orgs/sensecap-mx-team/apps/sensecap-hotspot/distribution_groups/public
HTH
GL :slight_smile: PJ

Indeed, that would be nice to know.

I’m concerned a little bit, that the folks of SeedStudio do read this forum and have no answer what to do in such a situation.

Thanx @PJ_Glasso but the link above does not point to firmware downloads of the “Sensecape T1000 Tracker”.

The only thing I can find about “sensecap t1000 firmware” is Firmware Release Note | Seeed Studio Wiki

Thanx, we tried that :wink: Without success :worried:

Also nothing to find at SenseCAP LoRaWAN Card Tracker T1000-A, indoor and outdoor positioning - Seeed Studio

But I contacted support from that site and asked for help. Will see if that helps…

2 Likes

Now I have the same problem, does anyone have the firmware file?

I tried searching all over the web, SeeedStudio support is not responding as well, and so I decided to reverse engineer, I was able to extract the firmware and restore my device. My tracker is now working perfectly :slight_smile:

if you guys need help, please let me know.

@cgmisola Please send me more info.

Here’s the latest firmware that you can use to manually restore your device, let me know how it goes

3 Likes

Thank you @cgmisola , after several attempts provided firmware will load, and t1000 will reboot with 2.5 firmware! Be aware to update with your phone close to the t1000, without any other bluetooth interference!