Sensecap M2 Gateway - Not Saving / Accepting Custom Server Addres in Packet Forward Mode

Hi everyone,

I have an M2-AS923 model with build version r1-20220615, recently updated to OS version 0.9.4-5.

I’m trying to configure it to communicate with our ChirpStack server. We have both a public-facing IP address and a DNS name available, with port 1700 enabled for both inbound and outbound traffic.

When I access the M2 Gateway via its web interface, I navigate to the LoRa Network Option and select Packet Forwarder Mode. There are two existing entries and an option for Custom. However, when I enter either our IP address or DNS name (e.g., and click apply, it says “applying changes” and starts a countdown from 90 seconds. Around 87 seconds, it says “changes applied,” but the same page then shows or, and the Custom field is blank again. It seems like it’s not actually applying the settings.

I also tried resetting the device by going to Restore > Perform reset and selecting “yes.” The unit goes offline, power cycles with the LED changing color, and comes back online. Interestingly, it retains my complex admin password, which I expected a factory reset would clear, reverting to the default admin/admin credentials.

I really want to get this unit working with our ChirpStack server. It worked in the past with the SenseCAP portal, and I have unbound it from there, but the issue persists.

Any help would be greatly appreciated.

1 Like