Seeeduino XIAO - read only file system

I can no longer load programs. I get the message that its a read only file system.

I don’t quite understand. XIAO has nothing to do with the file system. @alfons.vandaele

Let me explain:
When I connect the device I see the map CIRCUITPY appear on my computer. It contains the file When I try to read it, my text editor says: “The file …/CIRCUITPY/ can not be opened. Unexpected error: Error reading the file: input/output error.” When I open a picocom terminal, and use Ctrl-D to reload, I get the message: output:
OSError: [Errno 5] Input/output error.
I hope this helps?

Some more information. When I open the map in a terminal and try to remove the file, I get the following message:
alfons@Sirdal:/media/alfons/CIRCUITPY$ rm
rm: kan ‘’ niet verwijderen: Bestandssysteem is alleen-lezen
(Cannot remove ‘’: File system is read-only)
I also have tried it on another computer and have the same problems.

I think I solved the problem: I checked the partition /dev/sdd1 and found that it was damaged and could not be restored. I formatted the partition /dev/sdd1 again. And now it seems working again.