Seeeduino Xiao Programming Unreliability

I seem to be having intermittent programming my seeeduino xiao. I’m using the Arduino framework through VSCode on Windows (with whatever USB driver Windows auto-magically pulled for it). It’ll program without issue for some time but then it starts to fail programming and all I get is:
An error occurred while uploading the sketch
I’ve tried resetting the xiao
I’ve tried putting it in bootloader mode (it does go into bootloader mode)
I’ve tried different USB-C cables
I’ve tried unplugging the xiao for >5 minutes

Sometimes one of those three will work and I’ll manage to program it once before it goes back to failing other times it’ll program for another half day.

I’ve also started getting a USB device not recognized message when I plug the xiao in:


I also see the same behavior on my friends mac.

I can’t really discern any sort of pattern to any of it which makes me thing it might be something going squirrely in the lower level code but maybe its the USB driver?