Seeeduino xiao expantion board reset button not working

Hi !
First time here, and first time using the xiao.

I bought my board from mouser a few days ago, and it came very well packaged.

Unfortunately, no matter what I tried, I couldn’t get it to reset at all. Single press on the reset button, fast, slow, or not, it didn’t matter.

Since I am blind, I flashed the example buzzer song code in order to verify if the board was behaving fine. It did play happy birthday, but no matter how I tried again, it just would not reset.

I have not been able to put it in bootloader mode either. What should I try next ? I think I’ll have a hard time trying to short the pads, since I cannot see them at all. Did someone else ever had to deal with this ? How do I diagnose why the reset button of the expantion doesn’t work ?

Thanks !

Hi xogium!
I understand your current situation. But I am sorry for hear that. First, make sure your XIAO was correctly pluged into the middle of the two female header connecters. Otherwise the wrong connection will damage XIAO or expansion board.
If necessary, please contact your provider where you buy XIAO and return the XIAO.
Best wishes.