Seeeduino v3 does not work while Duemilanove/Uno work


I have a seeeduino 3 and a few other arduinos.

when I connect a grove base shield 1.3 with a led bar on it (or a four segment display) and upload code
from the samples, while all other arduinos (duemilanove, uno etc) work properly, the seeeduino does not

Specifically, when I connect the 4 segment grove led display ( … Path=34_78) to the D2 port and run the Timer example, it works only with the other arduinos but not on the seeeduino.

All uploads are properly done.

Do you have any pointers on what may be wrong/something I may be missing?


Hey, can Seeeduino v3 compile the program without errors? Or it can compile well but doesn’t get response from any examples?

Thanks for getting back to me!

It does compile normally. It uploads normally (at least judging by the lights flashing and stopping when the upload is done) but then it just does not do what it is supposed to do.

I tried code for an ethernet shield and still nothing happened.
(The same code run normally on UNO).

I also tried the blink example which does work normally.

Board type/COM port etc, all checked of course.

Thanks again!

it seems strange, could you show me the errors(pictures) while you are compiling the program…In fact, seeeduino v3 is the same to Arduino UNO,what the board you have chosen?

When compiling, it does not produce any errors. It compiles normally.

In order to upload it though, I select Duemilanove with atmega 328 and it does upload normally.

If I choose UNO for the board it produces the following error when uploading:

I also have a video with the whole process here:

Thanks again!

yeah , you need to choose Arduino Duemilanove w/ATmega328 when you want to upload program to Seeeduino v3, but not Arduino UNO.

Yes, this is what I always choose.

I always uploaded it as duemilanove. I still get the same behavior.

Anyway, i just discovered something weird that it can be seen in the following video.

After uploading the sketch to the seeeduino, if I lift one side of the grove shield,
the sketch starts to run. !!! If i push it back in, it freezes again !!!

So I start to believe that the whole issue has something to do between the two (the grove 1.3 shield and the seeeduino v3) as this does not happen with the original UNO.

Video link:

I did some more debugging and found out that the one pin that it is responsible for this behavior is the 5v pin:

If i get it out of the way, it behaves normally (the sketch runs)

Measuring the voltage on the pin, it outputs a staggering 7.48V!!!

while the UNO outputs the expected ~5v :

most probably, the voltage regulator is bust.

(the 3.3 volt output is okay btw)

Any ideas?

It’s really strange.
Just power from USB port, the voltage regulator will not affect the USB Power at all.
USB 5V Point.jpg
Please measure the voltage on C10.
Or would you please change a USB cable or a USB port on your PC.