Seeeduino v3.0 and I2C OLED

I’m having issues getting my I2C OLED to run. I have an official Arduino Uno and run this code fine:

<LINK_TEXT text=“ … h-arduino/”></LINK_TEXT>

but when I push the code to my Seeduino v3.0, the I2C OLED does not turn on.

Is there something else that needs to be done?

Hi @ssanchezg,

The I2C protocol communication based on the I2C Address, so make sure that you have correct address. the above tutorial they are using </s>0x3C <e> address . to better clarification can you mention which model OLED Display you are using?

sorry for the late reply. I didn’t seem have had my email notification on.

I am using this one:

0.96 Inch Yellow and Blue I2C IIC Serial 128X64 OLED Display Module for Arduino

I am trying to run the adafruit example with address 0x3C

I am facing the same problem, although I am using an Arduino Due + Grove-Base Shield + Grove OLED Display 0.96 inch v1.1.

I have two units and none of them seem to work and display any text (not conected at the same time). Tried three o four different examples with no luck. The oficial one for example ( does not work.

Any idea?

Thanks a lot!

I never got it to work. I just stuck with my Arduino. I may pick it up again and let you know here.

holly cow… I keep trying with no luck. No support from seeduino lads? :-/

If I am able to finally do it I will let you know too :slight_smile:

I just bought a seeeduino and it worked at first time… not sure why it did not work with Arduino Due.