Seeeduino uploading error

Hi there!
I’ve bought my seeeduino couple weeks ago and absolutely loved its innovations and slick design, but it worked for 7 days only!!! Now when I try to upload a sketch it returns error:

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x80
avrdude: failed to write flash memory, rc=-4
avrdude: stk500_recv(): programmer is not responding

TX and RX LEDs blinking for some time and then stop.
Seeeduino was connected to very simple board with 16 LEDs and two shift registers. All LEDs had 1k resistors and were powered from 5v pin. Seeeduino had a 9v battery supply, and was switched to 5v mode. It worked in such configuration for about a day and then stopped. I’m sure it isn’t my fault.

Would you please tell me what that error message means? And how to fix it if possible?

Hi Varl0n, Glad to have you lifted the problem to us.

Does other sketch work? Could you try re-program the bootloader ?

I’m not sure if this is static caused problem to damage the chip, or any component has visual failure by your visual inspection?

We will follow up with your case. Thanks!

Visually all components are in perfect condition, everything smells good, LED blinks when I power it up. TX and RX blink for some time when I try to upload a sketch, then everything stops. I can not upload any sketch. But I’ll try to burn a new bootloader tomorrow.
Glad you replied!

I have checked the guide on how to burn new bootloader. It says there are four pads written as X3 near FT232RL on a Diecimila PCB. But there is no such thing on a Seeeduino, or maybe there is, marked as something else? Where should I solder those pins?
Thank you!

It’s alive!!!
Using the guide that u gave me I fixed the problem! Everything working as it should! Sketches uploading, LEDs blinking!!!
Will buy more stuff from you soon!
Thank you!

Congratulations! :smiley:

Where did you solder the pins? Can’t seem to find x3

seeedstudio uart arduino x3
CTS –> 1
DSR –> 2
DCD –> 3
RI –> 4

I finally got it to burn the bootloader by switching the VCC to 3v3 and the RST to Manual. It worked for awhile and then started to error out again once I used my 9V battery adapter. It sill has the old code running but i cannot up load again. I noticed during the burn process my fuses an lock was different from the articles instructions.

efuse = 00
hfuse = d7
lfuse = c7
lock = 3f

Are these values correct? Should i be using the values from the article?

Hi thezim,

The original Arduino Duemilanove fuse setting is :

efuse 0x00
hfuse 0xdd
lfuse 0xff
lock 0x0f

So you’d better write it with fllowing command:

w efuse 0 0x00
w hfuse 0 0xdd
w lfuse 0 0xff
w lock 0 0x0f

And after 11/1/2008 we burn the bootloader as same as original Arduino Duemilanove .


I am having the same problem, thought I am currently temporarily solving it by placing the seeeduino in front of a heater fan for a minute or so. The problem seems temperature related, as I have only been having uploading problems recently, when we had bit of a cold spell.

The seeeduino is mounted on a (seeedstudio) harness, if that helps.


I managed to reproduce this issue again. I went into uni with my seeeduino and it will not upload again. Once placed next to an exhaust of a desktop computer for about 30 seconds, it was happy to upload.

Would this be a manufacturing problem?

I can say my issue was not fixed by reflashing the bootloader. I still had to apply hot air to the seeeduino in order for it to burn properly.

I suspect there might be an open contact in one of the SMD devices, and minute expansion of the board due to hot air closes the contact and allows programming to proceed.

Be nice to hear from other ppl. I would love to recommend the seeeduino to my friends and students, but as is I am hesitant to do so.


Hi steve:

We are sorry to learn that, how many degree do you got there? Is it OK to download sketch without heating it up?

All Seeeduino is burned bootloader, validated with test program before shipping. However, we are not able to test it under different temperature so this problem happens. Please let us know if you need a replacement, it would be great for us to have your cold-sick Seeeduino to study it thoughoutly and find out the root cause.

Thanks for lifting this issue! :wink:

Did a quick test, it doesn’t seem to want to upload under 27 degrees.

I would like a replacement if you find it is a genuine manufacturing error.

If you can provide me with RMA numbers, shipping address and so forth I will send it out.