Seeeduino stalker v1 - DS1307 not working

I got my seeeduino stalker v1 with date 12.18.2009 and it seem that the RTC chip DS1307 does not work :frowning:
I tried to run this program but the time is not running on the serial port output.

[code]/*Reads the value from a Real Time Clock (RTC) DS1307 and displays it in the serial monitor
*Created by D. Sjunnesson d.sjunnesson (at)
*Created with combined information from
*Big credit to mattt (please contact me for a more correct name…) from the Arduino forum
*which has written the main part of the library which I have modified

#include <WProgram.h>
#include <Wire.h>
#include <DS1307.h> // written by mattt on the Arduino forum and modified by D. Sjunnesson

void setup()

RTC.set(DS1307_SEC,1); //set the seconds
RTC.set(DS1307_MIN,23); //set the minutes
RTC.set(DS1307_HR,12); //set the hours
RTC.set(DS1307_DOW,4); //set the day of the week
RTC.set(DS1307_DATE,5); //set the date
RTC.set(DS1307_MTH,3); //set the month
RTC.set(DS1307_YR,9); //set the year


void loop()

Serial.print(RTC.get(DS1307_HR,true)); //read the hour and also update all the values by pushing in true
Serial.print(RTC.get(DS1307_MIN,false));//read minutes without update (false)
Serial.print(RTC.get(DS1307_SEC,false));//read seconds
Serial.print(" “); // some space for a more happy life
Serial.print(RTC.get(DS1307_DATE,false));//read date
Serial.print(RTC.get(DS1307_MTH,false));//read month
Serial.print(RTC.get(DS1307_YR,false)); //read year



I checked already the voltage on the chip where 3,3 V is on the battery pin and 3 V is on the VCC pin. Which seams strange, because it should work with 5 volts. Is it maybe a problem that I power the seeeduino only over USB?

Greetings from Vienna,

One hour later I found out what the problem was: On the Uarts Bee the switch for the power selector was on 3,3 V! After I changed this to 5 V every thing works fine.

So this issue is solved, but it maybe a good help reference for others who have the same problem.