Seeeduino Mega and Bluetooth Shield - What am I doing wrong?

I just received a new Seeeduino Mega and one of the seeeduino bluetooth shields and have been trying for the past two days to get the bluetooth working with no success. I am not sure if I am just missing something or if there is something wrong with the bluetooth shield. Here are the steps I have gone through, maybe someone will notice where I have gone wrong.

  • I have connected the BT shield by stacking it on top of the mega. From the first time I did this I have gotten the double flash once per second on the D1 LED.

  • I have tried the BT code on the BT Shield wiki to put the BT shield in the correct modes but see no sign of the BT shield receiving or responding to any commands.

  • I uploaded the modified code found in the BT help forum which added the “char” tags in the serial lines… no change.

  • I have tried different pins for the Rx and Tx including 14 - 19 which are tx1 and rx1 - tx3 and rx3 on the mega… no change

  • I also tried the modified code from the forum and attempted to use the sscomm software but get no response back for the seeeduino when sending commands.

Any additional information to help get this up and running would be great! Thanks!

Thanks for purchasing our product.
The standard NewSoftSerial library doesn’t have support for receive on the Mega. So if you use mega for your project, you can only use hardware software to communicate with Bluetooth Shield, that means only rx0 and tx0 can be selected by the jumpers.(make sure the jumper in the right place)