Seeeduino LoRaWAN no USB port detected after uploading sketch

We’re evaluating the Seeeduino LoRaWANs for use in workshops and was investigating a way to restore the factory DevEUI.

Mistaking the on-board ATSAM for the RHF76’s STM32, I copied the sketch found here to attempt to read the UUID:

After uploading the sketch the serial port disappeared from the host computer and I have not been able to get it back. I’ve tried combinations of the RESET and DFU button, different serial monitors, different computers, different OS’s, etc., but have never been able to detect the USB/serial port.

The board itself is functional - the PWR LED lights and the CHG LED flashes. If I press the DFU button the S LED flashes. But I cannot see how to restore USB comms with the host computer.

Is my only option to reflash the ATSAM using the SWD pads :?:

Less important: anyway to restore the factory DevEUI?

hi there

please try to press the reset button 2 times. thanks.

Wow, that worked! What did it do?