Seeeduino ethernet - ethernet not working - faulty unit?

Hi,

This is my first seeduino and my first arduino ethernet.

My seeduino ethernet works, but does no ever communicate over the ethernet. The ethernet link light is on and the recieve data light flashes, but the tx light never has come on. I would expect at least the briefest of flashes when it is trying to get a dhcp address?

I have tried various test code. The one on the wiki, test code from .cc and the examples in the application, but I always get the same result. When the app gets to Ethernet.begin(mac), it just stops. There is no trace of the unit sending any data and the dhcp server has no recall of it having requested an IP. I’ve tried setting an IP manually and it does progress past that point but still does not seem to talk over the network.

My code is basically this, though I tried lots of variants.

#include <Ethernet.h>
#include <SPI.h>


byte mac[] = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
byte ip[] = { 10, 0, 0, 177 };
byte server[] = { 64, 233, 187, 99 }; // Google

EthernetClient client;

void setup()
{
  Ethernet.begin(mac);
  Serial.begin(9600);

  delay(1000);

  Serial.println("connecting...");

  if (client.connect(server, 80)) {
    Serial.println("connected");
    client.println("GET /search?q=arduino HTTP/1.0");
    client.println();
  } else {
    Serial.println("connection failed");
  }
}

void loop()
{
 
}

Given the tx light on the board never flashes at all, do I have a faulty unit? I’ve exhausted every other possibility I can think of. Different power sources, different code, different othernet switches, etc.

Thanks for any advice. :question:

In the hope this helps someone else, I found part of the issue (and a whole bunch of others)

I had a simple (I thought) requirement. Log a few sensors, report over http and write data to sdcard. This board does not seem capable of this. I found some other reports including a post on seeeduinos site saying you cannot use sd and ethernet at the same time due to some spi conflict. Seeduino replied ‘we are working on it’.

USB doesn’t seem to supply enough power to the unit for reliable sdcard operation.
I got SD working most of the time with an external 9v psu.
DHCP does not work at all for me.
I Can initialise ethernet statically addressed and ‘ping’ the unit
Any attempt to use ‘ethernetclient’ results in the sdcard not working, the unit rebooting, or simply outputting continuously some debug via serial ‘istart’. This behaviour changes if you simply move a couple lines of code around. No real changes.

Overall, these units seem extremely flaky. The wiki examples in some cases are wrong (incorrect pictures and pinouts). The relevant inbuilt examples do not work for me.

If anyone actually has some working code for this type of app on this device, please can you let us know.

OK, gust to update anyone considering using a seeduino ethernet, DON’T!

I eventually bought an UNO and ethernet shield. Plug it in, using the same exact code I was uploading to the seeduino, it just works… No problem.

I wasted hours trying to get the seeduino samples to work. DHCP not working, etc. Put the same code on the uno and ethernet shield, just works. First time.

Seeduino, or mine anyway, waste of time! No support either.

Wow, I wish I had read this earlier. What a bunch of losers these guys at SeeedStudio must be! I am a software engineer and have an electronics degree and have designing, building and using elec. circuits for 30+ years. I got bored with the day to day stuff at work and picked up some Arduino stuff just to tinker with and have some fun. The ethernet shield seemed like a good place to start. I am now on my second SeeedStudio Ethernet shield 1.0 from Radio Shack. I took the first one back thinking it was defective. I was hesitant, but thought surely this thing shouldn’t be so difficult… Well, I guess I was wrong. All the pretty lights are flashing and it looks like it it is working its little butt off, but it will not connect to anything and always returns 0.0.0.0. I also tried several different examples. How can companies put stuff out like this? I will probably not take it back again and just chalk it up to a lesson learned which is probably just stick with the “official” Arduino stuff.

If anyone figures out how to get the piece of crap working please post instructions. Although I will likely go to Frys or MicroCener and get a real working board that works.

(Are you listening SeeedStudio?)

kev

Hello Folks,

I have 3 seeeduino ethernet (one working ok but I lost the software) and other 2 with problem on network… I download the following code (took it from arduino docs) and got the same result: Ethernet shield was not found

#include <SPI.h>
#include <Ethernet.h>

byte mac[] = {0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED};
IPAddress ip(10, 0, 0, 177);

void setup() {
  // Open serial communications and wait for port to open:
  Serial.begin(9600);
  while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB port only
  }

  Ethernet.begin(mac, ip);

  if (Ethernet.hardwareStatus() == EthernetNoHardware) {
    Serial.println("Ethernet shield was not found.");
  }
  else if (Ethernet.hardwareStatus() == EthernetW5100) {
    Serial.println("W5100 Ethernet controller detected.");
  }
  else if (Ethernet.hardwareStatus() == EthernetW5200) {
    Serial.println("W5200 Ethernet controller detected.");
  }
  else if (Ethernet.hardwareStatus() == EthernetW5500) {
    Serial.println("W5500 Ethernet controller detected.");
  }
}

void loop () {}

any clue?