SeeedStudio ESP32S3 Sense

I just got the Seeed Studio XIAO ESP32S3 Sense.

I am trying to upload the Blink example. But whenever I am trying to do it, it says Could not open Com6.

So i tried changing to ESP32S3 Dev Module, it successfully upload but then no LED is blinking.

Also the red LED near the Reset pin is bright at first but then is very dim subsequently. What am I doing wrong?

I had similar problems with an XIAO ESP32C3 and the nRF52840. My windows 10 laptop and Arduino would work for several compiles, then just stop with the XIAO boards. My Arduino board worked flawlessly every time. After trying to figure out when to double tap which reset button, then quickly select the correct USB port again… I finally gave up and went over to circuit python. Lots of people have the USB drive issue and I did not find a solid solution that permanently fixed it. I’m sure there is a solution, I just don’t have the patience to find it. I was not very far along in my project so switching over was not an issue for me.

Realized that I had to pick DFRobot Firebeetle 2 ESP32-S3 it managed to work after I tried uploading the Blink program.

But I am unable to make it work with the Round Display by XIAO.

you need to use XIAO ESP32S3 as your board or all bets are off, you cant just compile random boards and epect them to work, especially when using built-in led because the pin may change and some do not have a built-in led at all… smh

1 Like

Well, with DFRobot Firebeetle it works. Also, with the XIAO_ESP32S3 it works too. No error or anything. Managed to upload my code that I used in SAMD21. Thank you

Hi @mdabdillah @Greasenut

If you use xiao esp32s3, you must choose XIAO_ESP32S3 as your development board. If you encounter the problem of not being able to upload, please follow the Wiki steps to enter bootloader mode. Generally this solution can solve the xiao esp32s3 can’t upload problem

The red light next to the reset is the battery charging indicator.When XIAO ESP32S3 is not connected to the battery, the red light comes on when the Type-C cable is connected and goes off after 30 seconds.


I am using the XIAO ESP32S3 SENSE for image classification. I configured the board as per the requirements. the connection were all fine. however when i try to connect to the camera web server , i get some information like this


Build:Mar 27 2021


Saved PC:0x4037aeb6


mode:DIO, clock div:1





entry 0x403c9880

which means
ESP-ROM:** Indicates the version of the ESP32-S3 ROM (Read-Only Memory).
Build:** Specifies the build date of the firmware, in this case, March 27, 2021.
Reset Cause (rst):** The reset cause is 0x15, indicating a USB_UART_CHIP_RESET.
Boot mode (boot):** The boot mode is 0x8, indicating SPI_FAST_FLASH_BOOT.
Saved PC:** This is the address where the program counter was saved during the last reset.
SPIWP:** SPI write protection status is 0xee.
Mode:** DIO (Dual Input/Output) is the SPI flash mode used during boot.
Clock Divisor:** The clock divisor for the SPI flash is set to 1.
Load Addresses:** These lines show the memory addresses and lengths of various code segments being loaded during the boot process.
Why i am not getting connected to the wifi and not able to use the camera . can anyone help please ?

Initially I was not able to connect to Wifi.

A wifi scan was done and I saw the network I want to connect to.

The additional step I included was:


This sets the ESP32S3 to connect to an access point. After this, I was able to connect to Wifi and use the camera.

It worked for me now. Thank you!