Seeed Studio SXao nrf52840 sense not showing on Port in IDE

Extremely new here to this kind of controller. I got the new board and ran the simple examples in Arduino IDE environment. Everything seemed to work great.

I tried to upload a code and it seemed to get hung up with some errors. I unplugged the board and then pugged it back in. Once I did that, the IDE did not recognize the board. I was able to find a uf2 bootloader file and uploaded that to the board through the reset function.

I have sense tried some other code and seemed to do the same thing. But now when I plug the board into the USB of my computer, the computer states that board in not working correctly. The IDE does not recognize it on any of the ports.

What did I do wrong and how do I correct it. Remember I am an extreme newby to this type of thing, and need steps like you would give a 5 y/o.

Thank you for your help

This is the error I am getting - I have tried plugging the board into a different computer and same error. I plugged the cable into my phone to verify it wasn’t the cable. I also went into the device manager and uninstalled the USB and disabled it, but no luck


Hi Norman1950,
Try folloing steps.

  1. Connect to USB
  2. Press the reset button twice.
  3. File Explorer will open and XIAO_SENSE should appear as a drive. COMxx should be added to Device Manager. If this does not work, try several times.
  4. Open a simple “blink” sketch in ArduinoIDE
  5. In the Menu Tools–Port tab, select COMxx
  6. Compile and upload “blink”
  7. After successful upload, File Explorer will close automaticaly.
  8. Check the working of blink LED
  9. Check COM in the device manager or Tools–Port of ArduinoIDE, it should change to COMyy.
  10. Disconnect and reconnect USB, and COMyy should appear.
1 Like

Thank you very much and thank you for spelling it out very simple for me. This fix worked for me.