Seeed Studio Round Display for XIAO, Arduino fails to compile at the last step 'HardwareTest'

I have followed all the procedures from, Getting Started | Seeed Studio Wiki.
however, Arduino fails to compile at the last step ‘HardwareTest’.

I have installed, TFT library from, but get the same compile error.

arduino error message:
C:\Users\chris\AppData\Local\Temp.arduinoIDE-unsaved202413-6808-aw32y0.s4k6i\Test_Touch_Controller\Test_Touch_Controller.ino: In function ‘void loop()’:
C:\Users\chris\AppData\Local\Temp.arduinoIDE-unsaved202413-6808-aw32y0.s4k6i\Test_Touch_Controller\Test_Touch_Controller.ino:36:7: error: ‘class TFT_eSPI’ has no member named ‘getTouchRaw’
tft.getTouchRaw(&x, &y);
C:\Users\chris\AppData\Local\Temp.arduinoIDE-unsaved202413-6808-aw32y0.s4k6i\Test_Touch_Controller\Test_Touch_Controller.ino:42:33: error: ‘class TFT_eSPI’ has no member named ‘getTouchRawZ’
Serial.printf(“z: %i \n”, tft.getTouchRawZ());

Using library SPI at version 2.0.0 in folder: C:\Users\chris\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.14\libraries\SPI
Using library TFT_eSPI at version 2.5.34 in folder: C:\Users\chris\OneDrive\Documents\Arduino\New folder\Seeed-Studio-XIAO-Round-Display-lvgl8.3.5-main\Seeed-Studio-XIAO-Round-Display-lvgl8.3.5-main\libraries\TFT_eSPI
Using library FS at version 2.0.0 in folder: C:\Users\chris\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.14\libraries\FS
Using library SPIFFS at version 2.0.0 in folder: C:\Users\chris\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.14\libraries\SPIFFS
exit status 1

Compilation error: ‘class TFT_eSPI’ has no member named ‘getTouchRaw’

Yes i have been having trouble too… they say follow the wiki and it works but not yet for me… hve you tried other demo sketches in the TFTeSPI library?

Hi there,
SO which BSP file are you using for Which Xiao?
I think from a light look , the TFT_eSPI is the wrong one?
You need to remove what is present in the IDE (TFT_eSPI) and import ZIP from the WIKI link.
The standard one has NO “touch” keywords.
GL :slight_smile: PJ
check out the file versions, in the demo I posted, There is compiler output that list the versions.

I’m using XIAO_ESP32S3.
I’ve removed TFT_eSPI and installed the TFT_eSPI from the ZIP folder in the link.
I am now able to compile and upload the ‘Colour_test sketch’ from the TFT_eSPI folder.
However, I can’t compile the ‘Hardware test’ sketch from the Seeed_Arduino_Round_display folder.
…I’m not sure where to go from here?

Error message when trying to compile the ‘Hardware test’ sketch from the Seeed_Arduino_Round_display folder.

In file included from C:\Users\chris\AppData\Local\Temp.arduinoIDE-unsaved202414-22204-1yw9q5c.scqig\HardwareTest\HardwareTest.ino:8:
C:\Users\chris\AppData\Local\Temp.arduinoIDE-unsaved202414-22204-1yw9q5c.scqig\HardwareTest\lv_hardware_test.h:3:10: fatal error: I2C_BM8563.h: No such file or directory
#include “I2C_BM8563.h”
compilation terminated.
Multiple libraries were found for “SD.h”
Used: C:\Users\chris\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.14\libraries\SD
Not used: C:\Users\chris\AppData\Local\Arduino15\libraries\SD
exit status 1

Compilation error: I2C_BM8563.h: No such file or directory

YES… thats what it does…

but how do I get the ‘Hardware test’ sketch from the Seeed_Arduino_Round_display folder working?

Hi there
Great your on the right path.
What BSP are you using for it? ROLL it back.:wink::+1:
GL :smiley: PJ

I wish someone could just explain what is wrong so we can fix it

Sorry no idea what you’re referring to, What is BSP?

yeah… he uses alot of abreviations for things…

Hi there,
OK, So try to keep up here, less typing for me… :stuck_out_tongue_winking_eye:
It’s the Board Support Package that Espressif puts out for the hardware support.
(and the first line in the compiler output shows what’s used)

FQBN: esp32:esp32:XIAO_ESP32S3
Using board 'XIAO_ESP32S3' from platform in folder: C:\Users\Dude\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.8

A while back they put out one or two that didn’t work correctly in certain scenarios.
The term " Roll Back " refers to just that.(going back to the previous one) ie. when using the Gif example it would’nt run on the latest BSP “Alpha” Rolling back to 2.0.8 allowed it to work properly. (this is a normal part of the development process)

If folks are under the impression and think that ALL the code in examples and Wiki’s will always work , I have a bridge for sale.( with a spoon) :face_with_peeking_eye:
It’s incumbent on the user to educate themselves, starting with the manufacturer’s information and work forward. Changes they make is beyond the control of the Author or repackager of the code example being referred to. YMMV
GL :slight_smile: PJ

btw, you can google the abbreviations :stuck_out_tongue: :crossed_fingers:

1 Like

esp32 was 2.0.14, now rolled to 2.0.8…but still not compiling

…so, I deleted and reinstalled libraries from the tutorial to match the versions in the tutorial
TFT_eSPI was 2.5.34, now removed, and installed the version from the link, and modified the User_Setup_Select.h file

LVGL was 9.0.0, now rolled to 8.3.5
I2C BM8563 RTC was 1.0.3, now updated to 1.0.4
copied the lv_conf.h file from Seeed_Arduino_RoundDisplay, and placed it into the root directory of the Arduino library
…and the result…it compiled and uploaded!
thank you for providing help, it is very much appreciated.

1 Like

Hi there,
Good job, Great Step by Step account too…
Mark it as the solution Please so others can find and follow… :wink: :+1:
that compiler output will see in the Dark sometimes…LOL
GL :slight_smile: PJ

1 Like

how do I mark it as the solution?

Hi there,
Pick the post that had the info or suggestion. at the bottom like the heart or Flag …LOL
GL :slight_smile: PJ

FYI, I just realised the LVGL download from (Using LVGL and TFT for all XIAO Series | Seeed Studio Wiki) is for v8.3.4 not 8.2.0, or did I miss something?

1 Like