SEEED LoRa-E5 AT Command Not Responding on a Custom Board

I tested the Seeed Grove LoRa E5 and it worked well. Then I bought a number of Seeed LoRa E5 modules to use on custom boards. I followed the schematic shown in the datasheet but I am unable to get a response from the module. The pins RX and TX are read low (~0.8V) all the time. I modified the circuit on the Seeed Grove LoRa E5 to be identical to the circuit on my custom board. The Seeed Grove LoRa E5 still works as expected but the modules I bought from DigiKey do not respond at all.

My connections are :-

  • Vcc → 3.3V
  • All GND pins → GND
  • RST → pulled up with 10K ohms. Also tried floating
  • PB13 → pulled up with 10K ohms. Also tried floating
  • PB7 → FTDI TX ( operating at 3.3V)
  • PB6 → FTDI RX ( operating at 3.3V)

The module does not respond at all to AT commands. I noticed that the pins RX and TX are low; they measure ~0.8V. I doubt they have the AT commands firmware.

Are they all sold with the AT command firmware?

Yes, Grove lora e5 will burn in the firmware before shipping.

Thanks for the reply.

What about the modules like the one from digikey

DigiKey part# 1597-317990687-ND
Manufacturer Part# 317990687

They don’t respond at all.

This lora e5 you linked to will also be shipped with the firmware burned in. If there are any surprises you can contact your supplier for a replacement.

Any chance someone has a copy of the Firmware to restore the AT Commands?
I didn’t realize I was erasing the AT Command feature when removing the Level 1 Protection.

The AT firmware of the lora e5 is encrypted, once your program makes the original firmware lost, unfortunately you will have to buy a new lora e5 module.

What documentation is available to direct me how to write my own AT Command program?

The example of AT application from STM can help you: