Seeed Arch Pro Bootloader Update

Hi guys,

I recently received a Seeed Arch Pro (SAP) and I am having trouble with it. I was getting a lot of error messages about the DAPLink firmware being out of date and it wasn’t really behaving when I tried to use it, lots of resets and being re-detected by my PC. So, I tried to update the firmware following the steps provided; Download firmware, hold down button, connect USB to ‘debug’ port, copy bin to SAP, reboot. However, I was immediately struck with a problem that the .bin file I downloaded from the ARMmBed github was 60KB and the drive shown for the SAP (listed as “MBED LOADER” in windows) is 46KB. This in itself seems like a strange size and odd that the file provided was too big, seems like a very obvious oversight. The main problem now however is that will only boot with the button pressed. If I connect the board without the button pressed, nothing happens at all and MBED Studio does not recognise anything connected.

Can anyone offer any advice on this? Just for total clarity, the following info:

  • I am using a Windows 10 PC
  • I have a Seeed Arch Pro board
  • I have tried a number of micro USB cables
  • I have tried applying power to the other USB port in addition to the data cable in the debug port
  • I have tried disabling the Windows ‘Storage Service’

Any & all help greatly appreciated

@TheGoody Seeed Arch Pro is a joint product of Seeed and ARM Mbed. I believe that the design of ARM at that time must have its rationality.

@Baozhu I understand that this is a collaboration, however this does not help with the problems I am having. I have searched here and on the mBed forums and cannot find a solution.

I have now managed to restore the operation of the SAP, by reloading firmware from a Linux device. However, I am still unable to put the latest version of DAPLink onto the device, as its 60KB and the MBED_LOADER drive that appears when the SAP is booted with the button held down, is only 46KB. I do not understand how this Bin can be targeted for a device with not enough memory?!

Please can any one help?