Seeduino Starker 2.3 Startup Newbie

I have not done any project like this, I am a embedded software engineer and am around electrical engineers and was an electrical repair tech on Air Force Avionics equipment 40 years ago so rusty but have the tools to understand and learn.

I just received my Seeeduino Starker 2.3 and based upon the Wiki I installed the following drivers: FTDI on Windows 7
The driver appeared to install correctly setting up my usb port as:
COM 3, 9600 baud, 8 data, Parity none, stop bits 1, Row Control none.
I tried to use Putty serial interface setting the parameters as above but it is not connecting.

Lights on the board:
ok green
ch flashing red
pb0 flashing green

UartsBee V4.0

pwr green
txd no light
rxd no light

Pin Connections
Seeeduino - UartsBee
dtr - dtr
txd - rxd
rxd - txd
usb5v - vcc
gnd - cts
gnd - gnd

I am missing something, need help getting up and going. Other software?

Thanks in advance for your help.


I have exactly the same problem. If you find a solution, please write it to the forum.


I solved the serial port issue.

I am using something called Free Serial Port Terminal, which I got off the web and has a better serial application than Putty.

I also realized that I have not loaded a program to operate the device so all I can get is an echo of what I type. But that is ok because that is what I am getting now.

The next step I assume is to install a SD memory card to hold the program. I need to figure how to load the program. I’m hoping I can use a SD Card reader to do that then use the serial interface to talk to the device.

I’m pretty green on this but there is no out the box step by step process to follow so I’m talking it step by step.

Well, I haven’t gotten much farther, could use a post from some one who knows something.

After doing a lot of research, the SD card is for storing files not program code. What was I thinking, the equipment I load code on works very differently.

I found that my device has a boot loader on it and I have to use Arduino IDE to compile and upload Sketches. I downloaded 1.05 and 1.5.5 IDE and tried both, all get the same error:

avrdude: stk500_getsync(): not in sync: resp=0x00

The boot loader light is blinking, when the program loads the light stops blinking then blinks once and then I get the error. So I think I am communicating with the board, may be a program problem.

I now have the 1.5.5 version installed and have the processor set to: ATmega328 3.3v 8mhz
I have the board set to: Arduino Pro or Pro mini (Is this correct I have tried them all)
I have the port set to: COM3 (The correct port)
I have programmer set to: AVRISP mkII (Default) Should that change???
I am trying yo run the: Examples->Digital->BlinkWithoutDelay

Any help would be appreciated.

I finally solved my problem, the latest version of FTDI firmware is bad.

I was installing 2.08.30 D2xx drivers.

After an exhaustive search, got no help from this forum but found the answer by searching the Ardiuno Forum regarding the FTDI chip and the UartsBee V4.0 utility interface. There were some posts regarding rolling back the current software to 2.08.24 but I could only find 2.08.28 so I tried it and everything started working.

I am running Windows 7 so to roll the driver back I had to turn off Windows 7 Automatic Driver Install both during update and device install, then uninstall the drivers for both USB Serial and COM Port. Then reboot, first the USB Serial is installed from the 2.08.28 directory and then the COM Port is installed using the same procedure.

To verify the fix I used the Arduino Serial Monitor. I looped back the TX and RX pins but got no echo, after the new code was installed then I got the echo and the blink program worked. This was really frustrating, but nothing feels better than a little success!

Hi Mike

Thank you so much, that solved my problem!


I have ordered a Kit that included a stalker, solar cell, LiPo Battery and a USART and cord. After doing about 5 hours of reading on every possible wiki for the product I have found no reference to any driver changes for the 2.3 version. Pretty frustrating. To boot I have not seen any material question getting answered at this forum. My advice to anyone that doesn’t want to be super frustrated is to stay with Arduino products, and if you want help use the Adafruit Forum. They are the best.

Now about my problem with the Stalker Ver. 2.3 is that nothing compiles out of the box with out major ,major editing.
Not even the libraries compile. So what happens if you open up one of the examples, lets say this one Screen shot 2014-03-16 at 7.49.14 PM.jpg
If none of the libraries are written for the new version, and they aren’t , none of them will compile correctly. And as a result the example program has 25 lines of error messages.

If there is some one that has been busy re-writing the sketches for the Stalker 2.3 please speak up!