SD Shield V4

Hi Guys

i have an seeeduino v3 with an SD Shield V4 ontop, however the aduino default test program (cardinfo.ino) is continually telling me that i may have the wiring in correct or the wrong chip type selected, so questions:

  • am i supposed to solder the stackable headers to the SD Shield?
  • is the default chip type of 4 correct for the seeed SD Sheild

[code]/*
SD card test

This example shows how use the utility libraries on which the’
SD library is based in order to get info about your SD card.
Very useful for testing a card when you’re not sure whether its working or not.

The circuit:

  • SD card attached to SPI bus as follows:
    ** MOSI - pin 11 on Arduino Uno/Duemilanove/Diecimila
    ** MISO - pin 12 on Arduino Uno/Duemilanove/Diecimila
    ** CLK - pin 13 on Arduino Uno/Duemilanove/Diecimila
    ** CS - depends on your SD card shield or module.
    Pin 4 used here for consistency with other Arduino examples

created 28 Mar 2011
by Limor Fried
modified 9 Apr 2012
by Tom Igoe
*/
// include the SD library:
#include <SD.h>

// set up variables using the SD utility library functions:
Sd2Card card;
SdVolume volume;
SdFile root;

// change this to match your SD shield or module;
// Arduino Ethernet shield: pin 4
// Adafruit SD shields and modules: pin 10
// Sparkfun SD shield: pin 8
const int chipSelect = 4;

void setup()
{
// Open serial communications and wait for port to open:
Serial.begin(9600);
while (!Serial) {
; // wait for serial port to connect. Needed for Leonardo only
}

Serial.print("\nInitializing SD card…");
// On the Ethernet Shield, CS is pin 4. It’s set as an output by default.
// Note that even if it’s not used as the CS pin, the hardware SS pin
// (10 on most Arduino boards, 53 on the Mega) must be left as an output
// or the SD library functions will not work.
pinMode(10, OUTPUT); // change this to 53 on a mega

// we’ll use the initialization code from the utility libraries
// since we’re just testing if the card is working!
if (!card.init(SPI_HALF_SPEED, chipSelect)) {
Serial.println(“initialization failed. Things to check:”);
Serial.println("* is a card is inserted?");
Serial.println("* Is your wiring correct?");
Serial.println("* did you change the chipSelect pin to match your shield or module?");
return;
} else {
Serial.println(“Wiring is correct and a card is present.”);
}

// print the type of card
Serial.print("\nCard type: ");
switch(card.type()) {
case SD_CARD_TYPE_SD1:
Serial.println(“SD1”);
break;
case SD_CARD_TYPE_SD2:
Serial.println(“SD2”);
break;
case SD_CARD_TYPE_SDHC:
Serial.println(“SDHC”);
break;
default:
Serial.println(“Unknown”);
}

// Now we will try to open the ‘volume’/‘partition’ - it should be FAT16 or FAT32
if (!volume.init(card)) {
Serial.println(“Could not find FAT16/FAT32 partition.\nMake sure you’ve formatted the card”);
return;
}

// print the type and size of the first FAT-type volume
uint32_t volumesize;
Serial.print("\nVolume type is FAT");
Serial.println(volume.fatType(), DEC);
Serial.println();

volumesize = volume.blocksPerCluster(); // clusters are collections of blocks
volumesize *= volume.clusterCount(); // we’ll have a lot of clusters
volumesize *= 512; // SD card blocks are always 512 bytes
Serial.print("Volume size (bytes): ");
Serial.println(volumesize);
Serial.print("Volume size (Kbytes): ");
volumesize /= 1024;
Serial.println(volumesize);
Serial.print("Volume size (Mbytes): ");
volumesize /= 1024;
Serial.println(volumesize);

Serial.println("\nFiles found on the card (name, date and size in bytes): ");
root.openRoot(volume);

// list all files in the card with date and size
root.ls(LS_R | LS_DATE | LS_SIZE);
}

void loop(void) {

}[/code]

all help appreciated
r;0)b

Hey , if you use Seeeduino v3 (Arduino UNO) with SD card shield v4 , you need do nothing else but just compile the program ,then you will get:(picture 1)

So , could you show your errors(pictures) while you are compiling?
1.png

thanx for getting back

i am getting no compile errors, the output from the seeeduino is attached, i have also included pictures of the shield on the device, the sd card has been checked and is formatted FAT32.

any thoughts?
r;0)b

sdoutput.jpg
IMG_20130618_091248_953.jpg
IMG_20130618_091226_568.jpg
IMG_20130618_091216_037.jpg

hey , maybe it is the problem of your SD Card , could you tell me what the brand of your SD Card? Normally , you can use the SD Card from Seeed with Arduino/Seeeduino , and it works well. And we have found that some brands of SD Card can’t be detected by SD Card Shield.

thanx for getting back, i will try some different cards and let you know what happens ;0)

still no joy with this, i have tried a generic 2GB MicroSD (fat32), a cannon 16Mb SD (fat16)and a progressive 8Gb MicroSD (fat32), all of these can be read in my laptop but still get the same message as before, please advise? from my pictures can you confirm that i have correctly wired this device?

this is not how my shield is, on mine the headers are not attached to the board, see in the picture from the robotshop the headers are solderered onto the underside of the board?

is this because i bought direct from seeed in china?

and the robotshop have soldered it before selling or was mine just supposed to be soldered at the factory??

thanks
r;0)b