Please I need urgent help to get my .SD Card 4.0 shield to work with my Seeduino Mega ADK. I keep getting the message sd init fail.
I soldered the pins 11,12,13,4, 5v,gnd , Vin ,A0 and A4,
I have tried various connection 50-11,51-12,52-13, 53-4 etc but it is just not initializing.

SD card shield v4 can work with Mega directly without any other operation, but pay attention to the Supported Card Type and SD card format, normally, you need format your SD card in FAT16 or FAT32 type before use it firstly.


sorry chen but I ll like some clarification, do you mean I should mount the sd card shield directly on the mega such that 11>11, 12>12, 13>13, 4>4? My Sd card is in fat 32, I 've been using it in my mobile phone. and what about the SS and .CS pins. which is which and what settings am I to give them. thank you very much

Please just mount the sd card shield directly on the mega, more detailed information you can refer to the schematic of SD Card shield.

CS pin is digital 4, and SPI port has been used.

By the way, you may format SD card when using SD card at the first time.
SD card shield.png

You may have tried this already, but the correct connections should be 51-11, 50-12, 52-13. As for 53-4, that may be correct, but it could be 53-10. I’m certain its 53-4, but just keep that pin 10 in mind as well. :smiley:

Further, if you’re using an official arduino mega, you may have to leave it off of the unit itself and jump the pins over. I use two types of megas; one is an osepp and the other is an official arduino. The osepp works fine with the shield directly on it while jumping the pins over to the correct location. The other throws a fit when I have the shield directly placed on it. I still don’t really know why that is, and if anyone cares to explain I’d be grateful for that.

Another issue which I’ve faced, and am currently having an issue with right now is that some SD cards won’t work with my seeedstudio sd shield (version 3.0). I use a 16gb microsdhc card (class 4) from sandisk, and that works fine. I tried just yesterday an SDHC card, 16gb, class 4, from PNY and it does not pass the initializing tests in the IDE. Before anyone might say, “Check that the switch is in the correct position for the correct SD-microSD selection,” well it’s not that; I’ve tried it. Also, even though I found specs on the sandisk to be 3.3V, it won’t work unless I have it on the 5V on my mega. The only thing I can think of is write speed, but I doubt it, or maybe the PNY sd card requires something more than 5V? At this point I’m taking a shot in the dark.

I also forgot to mention that, yes, the PNY sdhc card has been formatted to FAT32 just like my sandisk microsdhc. :unamused: