SD Card not detected in Seeed Studio Nano

Dear Support Team,

I’m writing to report a problem with my Seeed Studio Nano, which is failing to recognise the SD card I’ve inserted. I’m using a SanDisk 32GB microSD card (SDSQUAR-032G-GN6MA) in my Ubuntu 18.04 host PC, and the details of the Seeed Studio Nano are as follows:

SKU : 110061362
Module: Jetson Nano 4GB Carrier Board Operating System:J1010 Carrier Board Power Interface: Type-C connector

I have checked the physical connections and ensured that the SD card is properly inserted into the slot. I have also tried the SD card in another device, and it functions correctly. However, when inserted into the Seeed Studio Nano, the SD card does not show up in the file manager, and I am unable to access its contents.

I expect the SD card to be detected and accessible from the file manager on the Seeed Studio Nano. However, despite multiple attempts, the SD card remains undetected.

I would appreciate any assistance or guidance you can provide to resolve this issue. Please let me know if there are any known issues related to SD card detection on the Seeed Studio Nano, or if there are any additional troubleshooting steps I can take.

Thank you for your attention to this matter.

Hari Prasath

Have you tried to use this Wiki to enable the SD card function?

1 Like

thank you for responding
The issue was resolved.