rpcWiFi lib compiling error

Hello, i am completely newbie and i am not able to compile easy network task from https://wiki.seeedstudio.com/Wio-Terminal-Network-Overview/
I installed all mentioned libs but anyway i got error : … Seeed_Arduino_mbedtls-master/src/port/esp_hardware.c:11:10: fatal error: esp_system.h: No such file or directory
** #include <esp_system.h>** What i am doing wrong ? I followed all steps. Thanks

Under the top menu in the Arduino app, the Tools menu, did you select the Board "Seeeduino Wio Terminal " ? Have you been able to compile any non-networking sketch ?

Yes, board is OK, i am able just few, only for built in LCD, almost nothing works.


usually i am getting such mess

Hi @EddieCz,
I suppose that you have installed the latest WiFi firmware (seeed-abd-firmware v2.0.3).
You can test which firmware is installed by calling rpc_system_version().
If the latest firmware is installed you have to include the rpcUnified and rpcWifi library. The atUnified and atWiFi libraries may not be included.
With regard to the Seeed_Arduino_mbedtls library it may be that you have to include the library from the dev branch (I’m not sure, may be that it was changed in the last days)

Hi, many thanks, tried this code
#include “seeed_rpcUnified.h”
#include “rtl_wifi/wifi_unified.h”

void setup() {

void loop() {

if i remove line with version, then writes hey, with this line is output empty :frowning:

What do you mean with seeed-abd-firmware v2.0.3 ?

I followed https://wiki.seeedstudio.com/Wio-Terminal-Network-Overview/
And flash went with success.

Hi, from your screenshot above you still compiling some of the old AT-framework Wifi libraries. Please make sure to remove them.

Also may i ask why are you including

#include “seeed_rpcUnified.h”
#include “rtl_wifi/wifi_unified.h”

in your code as the Unified library is used for more bottom layer software related. You may want to check out all the example in rpcWiFi before this :smiley:

1 Like

Simple answer, i dont know what to put or what to remove, so kept it there. If you want to learn smething you have to trust that examples are correct.

Solved ! Problem was when i tried to flash new firmware, it is important to keep new bin files in separate directory. Tool saves copy of old firmware in root folder and i wrote the same old files again and again. Would be perfect to mark it bold in instructions.
Thanks all for help.