RFBee Antenna problems

Hi, I just picked up a couple of RFBee’s to experiment with and I’m having a great deal of difficulty getting them to talk to each other. I’ve tried a variety of setups and have been able to communicate with both AVR’s just fine (using a couple of different micro controllers and a USB->XBee break out) but I can’t seem to get a round-trip packet between the two. I even tried taking the micro’s completely out of the picture by applying power to an RFBee and connecting it’s TXD and RXD pins together.

My most informative test seems to have come from hooking up an ATMega328p and programming it as a loop back. When I do that and monitor the traffic between the AVR and the RFBee I can see the expected traffic on a scope attached to the TXD and RXD lines, but nothing is making it back to the computer.

Swapping the RFBees around doesn’t seem to make any difference, neither does it seem to make a difference

So right now my test environment consists of one RFBee connected to a Fez Panda II, I verify that the panda can talk to the RFBee just fine, it can put it into command mode and fetch the Hardware and Firmware versions just fine and then it goes into a loop sending a single character, and waiting 500ms for a response.

The other RFBee is connected to an ATMega328p that is also verified to be talking to the RFBee just fine that is looping reading a character from the RFBee and sending it back.

After some playing with the antennas, the AVR is getting the right characters from the RFBee and sending the right characters back to it (verified with a scope).

The Panda is never getting anything back from the RFBee though.

Here’s possibly the most confusing part, swapping the RFBee’s makes no difference.

One other thing that I noticed, both of the Bees are supposedly v1.1 (so the silkscreen says) but one of them was reporting a hardware version of 1.0 while the other reported a hardware version of 1.1. I modified the firmware to write the 1.1 version into the EEROM and made sure that both of them are running the stock 1.1 firmware, but that doesn’t seem to have affected anything.

Dear customer,

According your description, I believe that all your hard ware would be find except Panda II.
You sure your Panda never receive any characters from RFBee?Try just connect with line with Arduino, check your pins is find.
Then if so, may be your code have some problem.
If you don’t mind, attach your codes and share at here, that could be more helpful to everyone to help you.

Best regards,


I might buy that as an answer if I hadn’t tried the experiment with multple different families of devices on both ends, includng just connecting the TxD directly to the RxD, using an atmega as a wraparound, and using the fez as a wraparound. I’ve tied just about, every permutation of avr, fez, USB serial, and direct loopback that I can come up with and can’t reliably get data to reliably between any two devices.

OK, I stripped this down to the simplest possible experiment. I hooked one RFBee up to a USB serial converter originally targeted at the XBee. The other RFBee is hooked up to power, a reset switch, and a logic analyzer.

  1. I reset the RFBee (call it RFBee #1) hooked up to the logic analyzer I can see the output from it “ok\r\n” as expected, so I can successfully see if there is output from the 168 on the RFBee.

  2. I can successfully put the RFBee (call it RFBee #2) hooked up to the serial converter into command mode and read the hardware and firmware versions, then put it back into data mode, so I am successfully communicating with the 168 on that RFBee.

3, I send characters to RFBee #2 through the serial converter, but nothing is received on the logic analyzer attached to RFBee #1.

If I swap the two RFBee’s, I can occasionally get some characters through if I hold both antenna’s between the same thumb and forefinger.

Clearly I can communicate with both 168’s, but there is definitely something broken between the 168’s and at least one, if not both of the 1101’s.