reTerminal user buttons not visible after upgrades


After upgrading the STM firmware to 1.8, flashing the “32-bit 2022-07-21-Raspbian-reTerminal” image, and running the dtoverlay script, the front user-defined buttons cease to work, and it’s not listed in evtest available devices.

Did I miss a step, has anyone had this issue? How to debug?

I saw the same behaviour with the latest vanilla Raspbian-lite image. My goal is to run openbox-session only and have the front buttons switch desktops (its so fast when it works)

Hi, please try to reinstall the driver

Hello Liu, thank you for your help. I have reinstalled the driver following the instructions exactly, but same result of no front buttons.

So I tried some experiments. Firmware version is latest 1.8 confirmed by running i2ctransfer -y 1 w1@0x45 0x97 r2 with response 0x01 0x08.

32bit 2022-07-21

  • Seems to contain 2022-06-19 image below

32bit 2022-06-19-Raspbian-reTerminal.img

  • Like brick, or not boot very far at all
  • attempted flashing 3 times to be certain

32bit 2021-06-02-Raspbian-reTerminal.img

  • image boots
  • front buttons work and exist as /dev/input/event0 gpio_keys
  • ran dtoverlays script, no obvious errors, rebooted
  • no front buttons
  • apt upgrade
  • still no front buttons
  • ran dtoverlays script again (to be certain), rebooted
  • still no front buttons?

32bit 2023-02-01 official raspberry pi os lite (my preferred setup)

  • image boots
  • no hardware support (as expected)
  • ran dtoverlays script, rebooted
  • hardware works but no front buttons
  • apt upgrade
  • no front buttons

I am not able to get a working configuration yet

Please try brushing in this image at
Open the evtest tool and enter 0.
Press F1.F2.F3.F4,and check their corresponding codes.
Open the config.txt and put
The specific value depends on the actual code of F1,F2,F3,F4