reTerminal / reTerminal DM - Yocto Kirkstone build failing


I would appreciate any help getting a base Yocto image rolling for reTerminal DM.
I’m not experienced with Yocto, so bear with me :slight_smile:

I’m trying to build in kirkstone release, so in the git repo root have submodules for:

  • poky - branch kirkstone
  • meta-raspberry - branch kirkstone
  • meta-openembedded - branch kirkstone
  • meta-qt5 - branch kirkstone
  • meta-seeed-cm4 - branch main

Then I have created the following script:

source poky/oe-init-build-env
# changes to build directory

bitbake-layers add-layer ${REPO_ROOT}/meta-raspberrypi
bitbake-layers add-layer ${REPO_ROOT}/meta-seeed-cm4
bitbake-layers add-layer ${REPO_ROOT}/meta-qt5
bitbake-layers add-layer ${REPO_ROOT}/meta-openembedded/meta-oe
bitbake-layers add-layer ${REPO_ROOT}/meta-openembedded/meta-python

MACHINE="seeed-reterminal" bitbake rpi-test-image

Please note I don’t have any custom layers. This fails with the following error:

| make[2]: *** No rule to make target 'arch/arm64/boot/dts/overlays/reTerminal.dtbo'.  Stop.
| make[1]: *** [/home/rd/x-yocto/build/tmp/work-shared/seeed-reterminal/kernel-source/scripts/ arch/arm64/boot/dts/overlays] Error 2
| ERROR: oe_runmake failed
| WARNING: exit code 1 from a shell command.
| make: *** [/home/rd/x-yocto/build/tmp/work-shared/seeed-reterminal/kernel-source/Makefile:1474: overlays/reTerminal.dtbo] Error 2
ERROR: Task (/home/rd/x-yocto/meta-raspberrypi/recipes-kernel/linux/ failed with exit code '1'

It is my understanding that it is failing to find the overlay definition.
I’ve tried the following, with identic results:

  • Changing MACHINE to seeed-reterminal-plus (for reTerminal DM)
  • Tried setting a different Kernel version (5.15)
  • Tried with the image core-image-base

I’m sure it’s a very tiny thing I’m doing wrong, but can’t really tell with my (ultra short) experience what it is.

Can anyone point me in the right direction?

Thanks in advance!

The issue was at meta-seeed-cm4, now solved!

It all now compiles successfully!


Thanks for giving the update.