reTerminal - Raspberry Pi black screen problem

I have confirmed a problem with the screen not displaying on certain Raspberry Pi OS versions, even with the latest reTerminal driver.

  • 2023-05-03-raspios-bullseye-armhf.img.xz
  • 2023-10-10-raspios-bookworm-armhf.img.xz
  • 2023-12-05-raspios-bookworm-armhf.img.xz

So I tried modifying the driver script.
Would you all like to try it?

If it works properly, please click :heart:(“like this post”).
If it fails, please let me know the image of the raspberry pi os you used and the steps to reproduce it. :pray:


  • I will modify the operation for Raspberry Pi OS. Unchanged for Ubuntu.
  • For Raspberry Pi OS, --keep-kernel option recommended. (DON’T upgrade the kernel.)
  • Raspberry Pi OS 64-bit kernel + 32-bit userland is NOT supported. (Change to 32-bit kernel + 32-bit userland with arm_64bit=0)

Install script for Raspberry Pi OS



This worked for me, all sorts of issues with blank displays. One thing I did need to do was pull the power out after the install, a reboot did not bring the screen back. Great work ! Running Bookworm (the Seeed supplied version, which did not enable the screen)

1 Like

Hi @lakid ,
Thanks for message. I am very happy.:blush::smile:

Could you tell me more details? I think I’ll try it out.

  1. Raspberry Pi OS image (e.g. 2023-12-05-raspios-bookworm-arm64)
  2. Did you apt upgrade before installing reTerminal Driver?
  3. What is the STM32 firmware version? (If you have installed reTerminal Driver, you can check it with dmesg | grep mipi_dsi. Latest version is v1.9.)
  1. 2023_11_15_bookworm_64.img
  2. No, the screen never worked with the image above. I followed your instructions from your branch on github and it all worked.
  3. [ 9.201813] mipi_dsi: (i2c_md_probe) STM32 firmware version 1.9

I’ve got an E10-1 expansion module and when that gets plugged in, the display doesn’t work and I get a ton of
Feb 09 10:39:42 reTerminal kernel: i2c-bcm2835 fe804000.i2c: i2c transfer timed out
in the logs
but thats another issue to tackle
thanks !

1 Like

Hi @lakid ,
Thanks for details!

I updated reTerminal driver.

  • Create a new installation script.
  • Added display settings and more
  • Support for Ubuntu 22.04

Please see the README file.