reTerminal Local Network Access Failure

  1. I can ping out from reTerminal and ping my reTerminal but every time I try smb or “network” to access a network NAS drive I keep getting the error “specified location is not supported”

You mean you are trying to access a NAS drive using the reTerminal? Are you connected via Ethernet or WiFI? Also, how are you accessing the NAS drive? Can you tell me the steps? I can reproduce on my end with my NAS and reTerminal.

Currently, I am using Ethernet. In a reTerminal TERMINAL window I can ping my NAS drive on my local network (192.168.1.xx). From my Windows 10 computer I can ping my reTerminal. I am connected to my NAS network drive all the time on my Windows PC. I also have a RP400 system running Buster from which I can access my NAS network drives using the File Manager and Networks. I can also gain access to the Internet

Steps attempted to access my local Network:

reTerminal “out of the box” going through Getting Started with reTerminal - Seeed Wiki (seeedstudio.com) Steps 1 – 10 but SKIPPING the update and upgrade!

Enabled: ssh, serial port, serial console (everything except VNC so far)

Then rebooted.

Checked Network and both eth0 and wlan0 are active.

Clicked on “Chromium” icon and navigated to several websites with no problem.

File Manager:

Click “Go”

Click “Network”

Result: “Error” “The specified location is not supported”

Type: Network://

Result: Nothing

Type: smb://

Result: “Error” “The specified location is not supported”

Tried to use “ssh” to login to reTerminal

Had to use ip address instead of pi@reTerminal…

Used the password I changed to and the default password and received:

Permission denied (publickey,password).

Never asked for username

I also have a RP 400 running Buster as well

When I click on File Manager “GO” and Network, I can see my desired NAS device. I can then Login to it. I did not Install any additional network related tools or programs.

Hello, could you please share the topological graph of the connection

Enclosed is a rough picture of my setup.
1 Wired Router, 2 Wireless Routers Meshed in AP Mode
1 NAS drive.
The wireless Routers and NAS are IP MAC Bound
Several wired computing devices and many wireless devices all managed by DHCP

I have other devices connecting and viewing my NAS drive without any problems, for example, Android and iPhone, RP 400, Raspberry Pis 4B, 3B, 2B. I have Fing on my Android phone and I see what I expect to see. The only system I am having trouble with, for whatever reason, is one out-of-the-box reTerminal and one re-imaged (with the lastest image from September 2021 - not the original). and yes, both times I followed the instructions so that I did NOT update or upgrade until I rebooted. On the re-imaged on I have installed circuitpython libraries, OpenPyXL plus other Excel and PDF python tools. Trying to troubleshoot the Network issue I also installed tools like:
thunar, samba, nmap, network-manager,
nmap could see my NAS with all its available services!
The power adapter came from SEEED (5V 4A), the one recommended. I also tried another (5v 3A). The power adapter did not have any affect.
The SSID WiFi name shows connected
The following were accomplished on the out-of-the-box reTerminal with no additional installs:

Researched networking and dhcp issues and have run the following - I do not know they all mean:
sudo service --status-all
of note: dhcpd, nfs and networking are running
$ grep -nrI Default-Start /etc/init.d
of note: /etc/init.d/dhcpcd:9:# Default-Start: 2 3 4 5
/etc/init.d/nfs-common:7:# Default-Start: S
/etc/init.d/networking:6:# Default-Start: S
/etc/init.d/ssh:7:# Default-Start: 2 3 4 5
pi@reTerminal01:~ $ systemctl list-unit-files | grep enabled
dhcpcd.service enabled
dhcpcd5.service enabled
networking.service enabled
raspberrypi-net-mods.service enabled
rc-local.service enabled-runtime
rc.local.service enabled-runtime
ssh.service enabled
sshd.service enabled
sshswitch.service enabled
nfs-client.target enabled
pi@reTerminal01:~ $ systemctl list-unit-files --type=target
network-pre.target static
network.target static
nfs-client.target enabled
nss-lookup.target static
nss-user-lookup.target static
64 targets
Does any of this help?

We will take the time to test it recently, so please wait until we have checked whether the problem is caused by the system.

Before doing so, we would like you to follow the instructions here to complete the installation of some dependencies.

I followed the instructions for creating a share point on the reTerminal. I was able to see the desired folder but could Not save a file. I received permission error.

Any luck testing the reTerminal and its access to a local network NAS drive?
I am but a beginner with all this, but is anyone else in the reTerminal world trying to access a local network - only using the Newest September 2021 image - no other network related installs? Or, am I the only one having this issue? If I am the only one, why?

R&D is already looking at this, it’s quite a complex issue and they need time.