reTerminal issue - who managed to install ubuntu 21.04 destktop?

Hi all
I just got me reTerminal yesterday
first boot was perfect but after I updated tthe system (sudo apt get update , sudo apt get upgrade). wifi ok, display and mouse ok at first boot, kb personnalisation ok.
once updated the rebooted, the first 2 sec of reboot, the dipslay because dark gray (white gray stripes). then no reboot was possible . dark display . impossible so ssh or ping the machine.
The wiki. seeedstudio. com/reTerminal/ page and forum.seeedstudio. com/t/new-reterminal-powers-up-with-blank-screen/259833 do not help much.

I was able to reflash the emmc with the default https://files.seeedstudio.com/wiki/ReTerminal/RPiOS_Images/2021-06-02-Raspbian-reTerminal-arm64/2021-06-02-Raspbian-reTerminal-arm64.zip . rebooted perfectly until the update crashes again.

I tried to install Ubuntu Desktop 21.04 64 bits (RPI4/400) . I can flash the emmc this no problem but impossible to boot at all. (no display but not surprising because the drivers are no installed at boot). While Raspberry PI imager was setup with ssh active, wifi SSID/pass ok. RJ45 pluged and linked ot my intranet switch… with 3 different power supply (up 5 amp). when POWE button is pressed, the P¨WR and SYS green led shows light for at least 10 to 15 sec, then switch off as if the device goes to off mode.

I follows the ubuntu install described on https://wiki.seeedstudio.com/reTerminal/ .
Am I using the right image ? Destktop 21.04 (2021/07/22 version) . Shoudl I use a 32 bit version ?*

Who manage to get ubunntu running on this device ?

I’ve had the same issue tried various flavours of Ubuntu 64 and 32 bit Desktop and Server and could not get any of them to boot. Currently I can only get the Seeed supplied Raspbian images to work.

Sadly, my experience is the same!

I have been able to get Ubuntu 20.04 up and running. My problem now is the the buzzer going constantly, I have reimaged the system to Raspian and as soon as I power up the reTerminal the buzzer hits a 8000Hz signal and will not reset, no matter what I do.

Seems like a motherboard issue. The buzzer stops only after fully booted. Now the USB ports do not recognize any devices that are plugged in namely a keyboard or USB storage device.

Also having this issue on Ubuntu 21.10, but looks like no one has a solution yet, unfortuntaely!

Having other issues simply trying to build anything other than the default image in buildroot. As soon as I change anything the configuration, it stops booting (although with slightly different symptoms). I did notice powering via a computer USB port can make a difference on whether it stalls on boot (presumably not quite enough power), but this didn’t make a difference after loading Ubuntu.