reTerminal DM Screen Blanking

How do I turn off screen blanking. Using the raspi-config GUI and Command Line utilities does not work. Screen always turns off. what makes it worse is after a few days it will go blank and never come back. Not usefule for HMI’s if I can’t leave the screen on.

Maybe you need to reinstall the driver.

This did not help. Still after some time I get a blank screen, It will wake up if I touch within a few hours, but after a day or so of it being blank ig will not come back… I am able to VNC into the device, and work with it that way, so I know the Pi is still awake, but without the screen coming on, it’s useless.

Hello, the problem of screen going blank and never coming back is a known issue of raspberrypi kernel.It’s still not fixed now.
I think you can try to turn off the auto sleep function of screen.
Here is the details:
1 open /etc/lightdm/lightdm.conf in your device
2 search the line of " #xserver-command=X", and change it to “xserver-command=X -s 0 -dpms”
3 save and close this file.
reboot the device and you screen will never go to blank.

I hope this will help you.

Thank you. Happy to report it no longer locks up, Still goes black, but at least it comes right up when you touch the screen now after 3 days.

Hi, I have understood the cause of the problem. I will discuss and study the problem with my colleagues this weekend. We will try to give you a reply next Monday

1 Like

Any updates on this issue? :grin:

any update?
I have the raspberry OS with debian BookWorm and after the driver installation the Display is not enabling.
This is a brand new device, with the factory installation it worked fine. If no news or no solution I will return it.

Hello, everyone.
We’ve updated the driver so that you can use it to light up the screen on your bookworm system.